Installation issues on Windows 10


#1

BUMP

OS: Windows 10 [ Occurred under both ver. 1803 & 1809]

Getting the same errors in log when I tried to reinstall via atom.io download and via chocolatey installer.

If it doesn’t error out the atom installer disappears, it appears to be installed but when I run it I get two processes of atom running with 0% cpu usage.

The processes are also locked from even as admin I denied access when I use taskkill or pskill to kill either process.


Instal error
#2

Oh I forgot to mention, the two processes that do run can only be seen as process.
There is no visible app to switch to.


#3

Try rebooting your computer (to kill the processes that you aren’t able to touch) and then run Atom from the command line with atom --safe to see if it does anything.


#4

I had, to the same result.

My first thought was it was somehow related to latest win10 update bug.
I am in the middle of a dev project so I needed to get back up and running asap and I wanted to see if any executables installers would run so I reverted to sublimeText.
It installed just fine.

I deleted all copies of AtomSetup-x64.exe/and the zips and redownloaded the the x64 executable.
After the Atom splash disappears… yeah, nothing.
The file looks installed at the location path, but when run creates to processes in the background that are untouchable. No electron app is rendered.

TaskManager--Atom

Yesterday, trying to reinstall/repair on-top of that install generated the Windows dialog that pointed to the log with the errors the OP. shared.
Today, I just tried again and it continues to fail silently, no dialog and no working app.


#5

Correction, when I tried to use atom --safe yesterday there must have been existing processes running when I looked.
Just tried again and nothing happens.
No error regarding missing executable yet no process is spun up.


#6

What happens if you rename the .atom/ directory in your user folder and then start Atom? Safe mode, purging the configs, purging the session memory, and reinstalling Atom are the four big things you can do to find out where a problem is coming from and potentially fix it.


#7

Sorry, been busy with a project.

Well, renamed .atom folder and that seems to have worked.
Atom opens up, finally!

I’m assuming that folder was corrupted somehow.
Is this a stable install still?


#8

Thanks btw!


#9

Your install is fine. Weird shit happens all the time, and sometimes some of the data that Atom produces for its own use gets messed up. You can probably fix it by deleting the folder compile_cache/.


#10

Good to know, like they say there’s a first time for everything.
Happy Holidays!