Installation issue on Windows


#1

here is stack:

Running “download-atom-shell” task

���⥬� �� 㤠���� ����� 㪠������ ����.
Aborted due to warnings.

What to do with it?


Win 7 x64 build issue
#2

Okay, problem is gone by itself.


#3

I got that error too. I don’t know if I messed something up, or if the build instructions in the current README.md are wrong. Here’s what I did:

  1. Installed all of the prereqs from the README (Note: I’m on Windows 8.1.) I had Python27 and Git installed already, but everything else was fresh. After the GitHub for Windows install, it asks you to log in to GitHub, but I just closed the window.
  2. Cloned https://github.com/atom/atom.git per the instructions
  3. Set my mail PATH environment variable per the instructions except added (x86) to Program Files for nodejs as that’s where the 32-bit version installs to by default.
  4. From the Windows Git Hub shell, I ran the specified commands.

Step 4 took quite a while. The very first thing it printed was:

npm WARN package.json github-url-from-git@1.1.1 No repository field.

Is that normal?
Finally, at the end, I got:

Running “download-atom-shell” task
>> The system cannot find the path specified.
Aborted due to warnings.

Since it seemed like it might be a PATH problem, I tried echo $path, which was empty.
Is that normal?

Next, I ran the script\build command from my normal Command Prompt (not PowerShell). This seems to have worked as it ends with Done, without errors. I do have cygwin in my normal PATH, so I don’t know if that made a difference. Maybe it was just a network fluke the first time that caused the failure and just running it twice would have worked.


#4

This is completely normal. When I was making my own windows builds for the public, I had those errors a lot. I got various errors including NPM warnings, node-gyp rollback errors, and file not found problems. These errors were all solved simply by running script/build a second time in the same command prompt.

I can also confirm that powershell is not needed, and that plain old CMD works just fine.