Installation issue on Ubuntu 16.04 [solved]


#1

Hello,

I am a huge fan of Atom and use it on regular basis at work on a Mac OS , mainly as a text editor.
I tried to install it on my personal laptop on Ubuntu 16.04, but I cannot find a way to get simple text editor features back. By this I mean the traditional presentation you have on the Atom.io website. You can check my screenshot, I am not even able to get the tab to visualize a document.

Note that I installed it with the .deb from the website. I also tried to add the ppa but the result is the same.
If you have an explanation to get the Text Editor back, thank you for your support

I’d also add that the ctrl+Q shortcut for quitting doesn’t work, and that have an error message in the console starting by
’ index.js:87 Error: EACCES: permission denied, open '/home/USER/.atom/compile-cache/less/df1b7fbc57dbeed23a8f1f8de95b4dfebcc06066/imports.json at Error (native) ’

even though I installed with sudo


#2

Sorry i couldn’t find the edit button for the body message, so I post the screenshotin a second message here


#3

This might be the problem. Try chown -R USER ~/.atom.


#4

thank you so much ! Ofc I had to add sudo before but it worked. I should stop this habbit of sudo install every package on my machine. Thanks