Installation has failed - IT policies access restricted


#1

Can’t install Atom, i get an error message saying “Unable to write to C:\ProgramData\Felipe - IT policies may be restricting access to this folder”. No error log is provided, running as administrator doesnt work either, and i dont think there is a ProgramData/Felipe folder on my computer.

Any help is appreciated.


#2

Forgot to mention, running on Windows 10 x64


#3

I have no idea what would cause your problem, but if you don’t find a solution, you can always install Atom in portable mode by downloading the .zip file for your OS and following these instructions.


#4

tried it but i cant get it to work either, i run atom.exe and nothing happens. should i try the update.exe first? idk wht to do, placed the folder with the .exe under %USERPROFILE%/Tools and added a .atom directory.


#5

What happens if you open the command line, navigate to the folder with the executable, and enter atom? Before you do that, you should open Task Manager and make sure there are no running tasks named Atom (you can kill them if there are).

You should check your environment variables and make sure there’s no variable called ATOM_HOME. At this point, the most likely thing I can think of is if that variable is set and overriding Atom’s normal behavior, but if you have portable mode configured correctly then that’s not the case.

Under Tools/, or in the folder with the executable?


#6

The directory is in tools, not in the same folder as the executable. Tried to open it with the command line but nothing happened, it loads for a sec but it doesnt open the window. A task is started which seems active but it doesnt do anything. I’ll check the environment variables later today and get back to you.

Any other ideas? Maybe portable mode isnt correctly configured, i just downloaded the zip, extracted it on tools and added a directory called ‘.atom’ and tried to open the .exe, am i missing something?


#7

That sounds right to me.


#8

the thing i do not understand is why its looking for the dir C:/ProgramData/Felipe, felipe is the name of the user, there is no folder named like that in program data.

and another thing, “felipe” is not the name of the main folder. i changed the user name but the main folder stayed with th old name, does that have something to do?

should i perhaps try to create that folder manually? i dont think messing with programdata is a good idea but i could try…


#9

Do you see that path anywhere in your environment variables? What happens if you open the command line and type echo %userprofile%?


#10

C:\Users\Maria

Only environment variables are ondrive, npm, and tmp/temp


#11

Captura2
This is the error but honestly im getting kind of tired, might just go download brackets.


#12

I suspect that this has something to do with how the user folder was renamed, but if I’m right, then troubleshooting it would require someone with a lot more knowledge about Windows’ user account system and registry than I have (or want to have). However, that doesn’t explain why Atom doesn’t work in portable mode.

Are you able to install Discord? It uses the same automatic updater as Atom.