Install Terminal plus package ......HELP...!


#1

I want to install the terminal plus package Link to Package but it has dependencies which needed to install but when i read the doc i got confuse so please can somebody help me…! I use windows 8.1


#2

At what point are you getting confused?


#3

check the link to install the dependencies See node-gyp install instructions

here i got confuse


#4

This is what you want.

Option 1: Install all the required tools and configurations using Microsoft’s windows-build-tools using npm install --global --production windows-build-tools from an elevated PowerShell or CMD.exe (run as Administrator).


#5

whats about this


#6

You can do that if you want. It’s more complicated, but that’s why there are multiple options.


#7

have u tried ti install the package


#8

I have it installed, yes.


#9

but still i am getting error to install dependencies


#10

You may want to contact the maintainer of the package for support. The Atom FAQ has information on how to contact the maintainers of any Atom community package or theme.


#11

Have you installed them?


#12

yes i have installed them


#13

Which option?


#14

following steps i performed while installing the dependencied

  • npm install --global --production windows-build-tools(Installed successfull)

then

  • npm install -g node-gyp (Installed successfull)

and then

  • apm install terminal plus

but still it gives that dependencies are not installed


#15

If the dependencies are successfully installed and the package still isn’t working, then that’s something to bring up with package maintainers.


#16

can u share ur steps how u install dependencies and all requirements to install this package


#17

I didn’t have to do anything extra to install terminal-plus because I already had node-gyp installed and working.


#18

after installing dependencies still i got this error

c:\Users\mandar\AppData\Local\atom\bin>apm install terminal-plus
INFO: Could not find files for the given pattern(s).
The system cannot find the file specified.
Installing terminal-plus to C:\Users\mandar.atom\packages failed
Failed to install terminal-plus because Git was not found.

The terminal-plus package has module dependencies that cannot be installed witho
ut Git.

You need to install Git and add it to your path environment variable in order to
install this package.

You can install Git by downloading, installing, and launching GitHub for Windows
: https://windows.github.com

Run apm -v after installing Git to see what version has been detected.


#19

The package has appeared abandoned for quite a long time.

Latest commit Nov 26, 2015
215 Open Issues

Majority of its users (yours truly included) are using this fork, which is working without issues.


#20

As the error suggests, you should install Git.