Install Atom As Standard User On OS/X


#1

Hi!

I work almost exclusively on OS X and I would like to be able to compile Atom from source code and install it to my ~/local/bin as a standard user. I do not want to install it system-wide as an administrative user. With the latest ‘git pull’ as of this moment, my Atom compile fails at the Install step.

d57:atom gbwk$ ./script/build
Node: v0.12.3
npm: v2.5.1
Installing build modules...
Installing apm...
child_process: customFds option is deprecated, use stdio instead.
child_process: customFds option is deprecated, use stdio instead.
child_process: customFds option is deprecated, use stdio instead.
Installing modules ✓
Installing one-dark-ui@0.8.2 ✓
Installing one-light-ui@0.8.2 ✓
Installing autocomplete-plus@2.17.1 ✓
Installing autoflow@0.24.0 ✓
Installing deprecation-cop@0.51.0 ✓
Installing find-and-replace@0.167.0 ✓
Installing fuzzy-finder@0.87.0 ✓
Installing keybinding-resolver@0.33.0 ✓
Installing metrics@0.51.0 ✓
Installing notifications@0.50.0 ✓
Installing open-on-github@0.37.0 ✓
Installing settings-view@0.205.0 ✓
Installing snippets@0.90.0 ✓
Installing status-bar@0.73.0 ✓
Installing wrap-guide@0.34.0 ✓
Installing language-clojure@0.15.0 ✓
Installing language-css@0.30.0 ✓
Installing language-gfm@0.76.0 ✓
Installing language-php@0.24.0 ✓
Installing language-python@0.35.0 ✓
Installing language-ruby@0.54.0 ✓
Installing language-shellscript@0.15.0 ✓
Installing language-todo@0.22.0 ✓
Installing language-xml@0.30.0 ✓
Deduping modules ✓
Running "download-atom-shell" task

Running "download-atom-shell-chromedriver" task

Running "build" task

Running "coffee:glob_to_multiple" (coffee) task
>> 327 files created.

Running "prebuild-less:src" (prebuild-less) task

Running "cson:glob_to_multiple" (cson) task
>> 170 files compiled to JSON.

Running "peg:glob_to_multiple" (peg) task

Running "generate-license:save" (generate-license) task

Running "generate-module-cache" task

Running "compile-packages-slug" task

Running "copy-info-plist" task

Running "set-version" task

Running "generate-asar" task

Running "install" task
Aborted due to warnings.

I also notice that the “automatic” OS/X version updates must be done when logged in as an administrator. I do all my work as a standard user and would like to keep it that way for most of my software.

Thanks for any advice and help you can provide.

Bob


#2

When you run script/build you can give it an alternate installation location like so:

script/build --install-dir ~/local/bin/Atom.app

And if you build from source, the application doesn’t try to update itself … so you’re good there too.


#3

Thank you! This worked. I had previously installed Atom as an administrative user, I will now try to remove that version (in my Applications folder) and play with the standard-user version of Atom.

Bob


#4

It does appear that if I want to “instal shell commands” as a standard user, I can’t do that without supplying administrative credentials. That is, if I

open -a ~/local/bin/Atom.app

and then within atom:

cmd-shift-p
install shell commands

…an OS X popup Window appears requiring an administrative user name and password.

Any advice for getting e.g. shell commands or packages to install under the user’s login and home directory, rather that the OS/X system?

Bob


#5

You can install them and then just move and/or edit them. I believe they respect the ATOM_HOME environment variable.


#6

Thank you. Let me explain (in case that has been unclear) that at first, I tried to install Atom from source code, on May 15. Then, since that errored out and I was interested in using Atom, I downloaded thje Mac OS X installer and installed that, also on May 15.

It looks like this created some symlinks (again on a fully up to date OS X Yosemite system):

$ ls -al /usr/local/bin
total 24
drwxr-xr-x  5 root  wheel   170 May 15 21:46 .
drwxr-xr-x  3 root  wheel   102 Oct 17  2014 ..
lrwxr-xr-x  1 root  wheel    71 May 15 21:46 apm -> /Applications/Atom.app/Contents/Resources/app/apm/node_modules/.bin/apm
lrwxr-xr-x  1 root  wheel    53 May 15 21:46 atom -> /Applications/Atom.app/Contents/Resources/app/atom.sh 

…and I think Window: Install Shell Commands is influenced by the above. I have set ATOM_HOME to ~/.atom . I’m not sure if I also need to set an ATOM_PATH (that points to ~/local/bin?)

I will keep experimenting and see what happens. Thanks again!

Bob


#7

If you just change those symlinks to point to the same path relative to your new install location, everything should work fine.


#8

Thank you very much for helping me through this. I had already removed the symlinks entirely before seeing your post. I’ll restore them but point them to the new install location.

Bob