Input boxes blackout when Atom window is maximised


#1

A few days ago I installed Atom for the first time. Just now I started using it.
There is something weird with the Editor Settings form.
All input boxes are OK when the Atom window is not minimised.
All input boxes blackout when the Atom window is maximised.
See screenshots.
I couldn’t find any other topic mentioning this. So I assume it must be on my end.
What can I do to resolve this?

Happens on Manjaro Linux (4.8.1 kernel) with Gnome 3.20 desktop.

Atom window maximised :


#2

Atom window smaller :


#3

With the Atom window maximised, clicking inside any of the input boxes places a blue border around the input box and reveals the blacked out content.


#4

Are you running Linux in a VM? Perhaps VirtualBox? If so, you may want to disable 3d acceleration in the VirtualBox settings for your VM. If not, it may still be a video acceleration issue … you would simply launch Atom with atom --disable-gpu as mentioned here:


#5

No I’m not running Linux in a VM. I’m multi-booting into Linux.

I tried with the suggested option --disable-gpu from the commandline (see scrfeenshot).
And by adding it to the desktop file /usr/share/applications/atom.desktop.
Both times no luck.


#6

Can you replicate the same problem in Chrome?


#7

Maybe, if you tell me how.


#8

I would start by opening a web page that has input boxes, for example http://www.google.com, and maximize the browser window. If that doesn’t work, I’d move to one with a dark theme like this one: http://codepen.io/natewiley/pen/yakLgb


#9

The issue occurs only in Atom.
Everyone who visits here must have Chrome open on a daily basis. Almost all day.
I would have noticed it.
I had hoped that opening the Atom settings pages (HTML and CSS ?) in Chrome was possible. I did a quick search for them. But no luck. Probably dynamically built.

Let’s forget it. We’ll see what happens in the future. It’s not a showstopper because the editor is OK.