INFO: Could not find files for the given pattern(s)


#1

So after installing Atom, I have the User path of apm.cmd already set.

But yet when I call upon “apm” I get the following by Windows 10: “INFO: Could not find files for the given pattern(s)”

this is quite frustrating because this is starting just after having to reinstall Atom after a recent update.

If anyone can re-create the following for testing:

install Atom (beta), install a few packages, update when a new beta version comes out, then uninstall and reinstall, and then play with the apm in the CMD prompt (not PowerShell); see what happens.


Apm command error
#2

Check and see if you have two different directories with apm.cmd. That error means that the batch file you’re invoking can’t find the executable it wants.


#3

I have the same issue.

I checked if I had multiple directories with apm.cmd but running where apm.cmd only yielded me the following results : C:\Users\Akaizoku\AppData\Local\atom\bin\apm.cmd

Problem appears on multiple environments since the new update.


#4

Okay. Please open apm.cmd, post the contents here, and then go look manually and see if the path it points to exists. It should point to app-1.10.2\resources\app\apm\bin\apm.cmd.


#5

My result was as follows after using the .bat file

>apm_find.bat
Is "apm.cmd" installed?
"file ("apm.cmd") found"
"file ("apm.cmd") found"

And to clarify, the way it goes is like this: say I just type “apm” right? I get the following

>apm
INFO: Could not find files for the given pattern(s).

apm - Atom Package Manager powered by https://atom.io

Usage: apm <command>

where <command> is one of:
    clean, config, dedupe, deinstall, delete, dev, develop, disable, docs,
    enable, erase, featured, home, i, init, install, link, linked, links, list,
    ln, lns, login, ls, open, outdated, publish, rebuild, rebuild-module-cache,
    remove, rm, search, show, star, starred, stars, test, uninstall, unlink,
    unpublish, unstar, update, upgrade, view.

Run `apm help <command>` to see the more details about a specific command.

Options:
--color        Enable colored output  
[boolean] [default: true] 
-v, --version  Print the apm version
-h, --help     Print this usage message

Prefix an option with `no-` to set it to false such as --no-color to disable
colored output.

So apm works, as it should, but now I’ve got two apm.cmds: one that is a “blank” file and another that’s a .cmd file

   app
│       │   └───apm
│       │       │   BUNDLED_NODE_VERSION
│       │       │   CONTRIBUTING.md
│       │       │   deprecated-packages.json
│       │       │   LICENSE.md
│       │       │   package.json
│       │       │   README.md
│       │       │
│       │       ├───bin
│       │       │       apm
│       │       │       apm.cmd
│       │       │       node.exe
│       │       │       npm
│       │       │       npm.cmd

As to what I get when I enter “where apm.cmd”?

>where apm.cmd
C:\Users\USER\AppData\Local\atom\bin\apm.cmd

#6

Which one is blank? Is it actually blank?


#7

Which one is blank? Is it actually blank?

Apologies (wrote the reply at 02:00), the apm file with no extension showing seems to be nothing more than a bash script file of sorts (.sh) because checking the file has the following

#!/bin/sh
"$(dirname "$0")/../app-1.10.0-beta5/resources/cli/apm.sh" "$@"

While the “apm.cmd” file has

@echo off
"%~dp0\..\app-1.10.0-beta5\resources\app\apm\bin\apm.cmd" %*

#8

Okay, so back to my earlier question. Does app-1.10.0-beta5\resources\app\apm\bin\apm.cmd exist?

From the output you’re seeing, it’s obvious that you have two instances of apm.cmd in your path and one of them doesn’t actually have anything to point to. Since the current beta version is 1.11.0, it’s probably the one pointing at the 1.10.0 directory.

That’s the Unix version.


#9

yes, it does exist.


#10

Do you have 1.11.0 installed?


#11

No I do not have it installed


#12

Then what update did you install? In your first post, you said that you had just updated. 1.11.0 is the current beta version.

I believe I’ve solved the problem. You appear to have two apm.cmds sitting around and both of them are in directories on your PATH, so the command line invokes both. One of them points to a target that doesn’t exist, hence the error. Since I cannot look through the files on your computer, you’ll have to find it yourself.


#13

I did not actually state any version initially and someone replied to you other than myself (Akaizoku)

would you like me to update my beta install (I’m sorry for not specifying first-hand what version I installed)


#15

If you say that you have just recently updated, everybody’s going to assume you are on the most recent version.

would you like me to update my beta install

Do what you want. It probably won’t find that extra file, though. You’ll have to look for it.


#16

The only things I found that were on the User Variables PATH set by Atom were:

C:\Users\USER\AppData\Local\atom\bin


#17

Looking at your first post, I see that you specify “not PowerShell”. Why not PowerShell? What happens when you use PowerShell?


#18

No reason in particular. Just a mention to assure consistency for recreation.


#19

Well, if you can’t find another one, deleting the whole of AppData/local/atom and reinstalling Atom might be the best thing.


#20

I have tried that within the last few days only to no avail. I wonder if it’s registry related. Because it cannot be that simple unless it’s something else.

I’ll get back to you on this topic when I do figure something out.


#21

And when you search for apm.cmd, you only find the ones in atom/bin and app-1.10.0-beta5?