Increase space b/t gutter and line start


#1

I find myself accidentally clicking the gutter and hiding blocks constantly. quick and dirty code to give myself a bit of unclickable padding between the gutter and start of a line?


#2

Try this. Not only will it increase the space between the text and the fold markers, but it will give you a clear line between editor and gutter.

atom-text-editor .gutter-container div::after {
  content: "";
  width: 5px;
  margin-right: 3px;
  background: -webkit-linear-gradient(left, #111 0%,#282c34 100%);
}

#3

mmm, not quite. this widens the gutter but doesn’t give me an unclickable non-space, you know? clicking on the widened gutter still collapses blocks.


#4

alternatively, you could just help turn off block collapsing. I never use it.


#5

This is unusual behavior. I have to move my mouse onto the gutter far enough for the arrows to appear before clicking does anything. You don’t have a package that interacts with code folding, do you?

I don’t know if there’s a way to turn off folding entirely.


#6

turned all my comm pkgs off to test, no dice. I’m on 1.18 after the rocky rollout of 1.19 a day or so ago, maybe that’s affecting it?


#7

GOT IT. found an old answer. this disables folding like a charm:

atom-text-editor::shadow .gutter .line-number .icon-right {
display: none;
}


#8

Hi.

Nice solution! … but drop the ::shadow part.
My suggestion from this posting:

atom-text-editor .gutter-container div::after {
  content: "";
  width: 5px;
  margin-right: 3px;
}

atom-text-editor .gutter .line-number .icon-right {
  display: none;
}

Alternate:

atom-text-editor .gutter-container div::after {
  content: "▐"; // for a decorative mood
  margin-left: 0px;
}

atom-text-editor .gutter .line-number .icon-right {
  display: none;
}