Impossible to code since 0.125.0: many freezes


#1

Hi,

I just updated my Atom this morning. I’m on Mavericks Retina. This is awful, when I’m starting to type some code, Atom Helper goes up in CPU, the autocomplete feature is frozen, I can’t do anything.

I asked my coworker to download the update and same issue. I don’t use external softwares, just Chrome. I disabled my Linters (CSS/JS/PHP) and still the same.

When I double click on a file (tree view) it takes 3/4s to open.

I suppose that I can’t downgrade to 0.124 ?

Thank’s


#2

Before downgrading, make sure that this is not due to a package by running atom --safe.

Also, check the deprecation cop (Deprecation Cop: Show command in the palette), there’s probably some packages that have registered to some input event and that relies on deprecated API, resulting in a bottleneck in the deprecation cop itself. It should allow you to track which package is drowning the perfs.

If after that you still want to downgrade to 0.124, all the release are available here:


#3

Agreed. There is a lot happening to the API recently, so quite a few packages will be somewhat behind on those changes.
But even if it’s core, that is also in a rather fluid state these days.


#4

Thank’s, it’s OK with safe mode.

Many deprecated calls:

Editor.lineForBufferRow (called more than 250 times)
Editor.getSelection (called 20 times)
TextBuffer.on (called 17 times)
EditorView.getPane (called 6 times)
EditorView.pixelPositionForBufferPosition (called 4 times)
Workspace.getEditors (called 3 times)
Workspace.eachEditor (called 2 times)
Workspace.on (called 2 times)
Editor.getCursor (called 1 time)

apm list

├── angularjs@0.0.5
├── atom-alignment@0.9.3
├── autocomplete-plus@0.21.0
├── color-gutter@0.3.1
├── emmet@2.1.3 (disabled)
├── git-diff@0.39.0
├── git-log@0.1.2
├── highlight-selected@0.6.0
├── language-php@0.15.0
├── linter@0.6.0
├── linter-csslint@0.0.11
├── linter-jshint@0.1.0
├── linter-php@0.0.11
├── monokai@0.7.0
├── monokai-soda@0.3.0
├── open-last-project@0.1.1
├── select-line@0.16.0
├── seti-monokai@0.3.1
├── seti-syntax@0.1.7
├── seti-ui@0.3.5
└── travis-ci-status@0.11.0

#5

@sylouuu

I had the same problem, the slowness disappeared by setting color-gutter to disabled.