Impossible launch on ubuntu through x2go client


#1

Hi,

For several days now I can’t launch atom. I 'm using ubuntu 15.10 and atom v1.5.4, I’m trying to launch it through X2go client. I think the problem is related to that but I’m not sure. I can launch it from the physicial desktop with another user but not mine, even on my physical desktop.
If I launch Atom in a terminal I just have this: App load time: 431ms

Already tried to remove the .atom in my home folder and also the Atom in.config and then resintalled it but nothing have changed.
maybe it’s related to that: Cannot use Atom in Ubuntu with multiple users but I’m not convinced.

What can I do to debut it?


#2

I’m not sure what the “x2go client” is. Also, did you install using the instructions from the website? Or did you install from an unofficial PPA like in the other topic?


#3

x2go is an … how do I explain that. It’s kind of a vnc over ssl. It’s the opensource project of the protocol that use nomachine. It creates a virtual desktop or it can link to the physical desktop too.
I’ve used the .deb from the website, don’t know if I had to do something else than install the.deb.


#4

Ok, I’m passably familiar with NoMachine. No, you shouldn’t have to do anything other than install the .deb. It’s possible that Atom is displaying on the physical display and not the virtual display that NoMachine sets up.


#5

Ihave access to the physical display as well and is not displaying. In fact the process stop itself and I don’t see why, without any information displayed on terminal


#6

is there some logs where I can find why the process stops?


#7

Not that I know of, no. I’ll double-check with some of the other team members though.


#8

I encountered the same problem. I hope this issue is solved because I would like to use Atom as a primary editor and to work remotely from my macbook (atom is installed in remote Ubuntu machine). With X2go, I was able to run Chrome but cannot run Atom.


#9

Great I’m not the only one. So I can confirm that with the new version 1.6 it’s always the same problem.
So please can you maybe put a verbose mode in atom?


#10

Version 1.0.19 of atom and 4.0.3.1 of x2go:

Unfortunately this combination doesn’t seem to work. Which is odd because it does work with x-forwarding (though is expectedly slow).
i.e.
ssh user@server -X atom

Atom appears to only run in x2go if you connect to “local desktop”.


#11

okey but I think I was able to work with it without to be connected to the local desktop before.
At least it’s good to know that I’m not hallucinating. but why using so old version?
Anyway Could we have some follow up on this matter?


#12

just for information still the same problem with ubuntu 16.04 and atom 1.7.4 …
I’m still thinking that it shouldn’t be complicated to add a feature to be able to see atom through remote on virtual screen


#13

I encountered the same problem.

Software versions are
Atom : 1.8.0
Electron: 0.36.8
Chrome : 47.0.2526.110
Node : 5.1.1

x2goagent: 3.5.0.32
x2goserver: 4.0.1.19
x2goserver-extensions: 4.0.1.19
x2goserver-xsession: 4.0.1.19


#14

Following the discussion(https://github.com/atom/atom/issues/4360), I’ve got to launch atom via x2go.
It worked for me on both Ubuntu14.04 and 16.04.

My steps are:

  1. Find libxcb.so*. (e.g. find /usr | grep libxcb.so)
  2. Find atom installed directory. (dpkg -L atom)
  3. Copy libxcb.so* to atom installed directory.
  4. Modify libxcb (e.g. sed -i ‘s/BIG-REQUESTS/_IG-REQUESTS/’ libxcb.so.1.1.0) that is in atom dir.
  5. Start atom.

#15

did you put it in a specific subfolder? because for me it’s /usr/share/atom but it didn’t change a thing … Xégo is create virtual desktop on your part or do you use as a remote desktop only?


#16

does someone succeed it to do the same?


#17

Did you try /opt/atom?


#18

It worked for me on CentOS 7 with XFCE on X2GO with both the Website Version of Atom and the COPR Repository Version:

Instructions:

METHOD 1: WEBSITE VERSION OF ATOM

yum install libXScrnSaver redhat-lsb-core.x86_64 libXScrnSaver.i686
wget https://atom.io/download/rpm
mv rpm atom-date +%b-%d-%Y-Centos7.x86_64.rpm
rpm -ivh atom-Centos7.x86-64.rpm
yum install libxcb.x86_64
cp /usr/lib64/libxcb.so.1 /usr/share/atom/
cd /usr/share/atom/
sed -i ‘s/BIG-REQUESTS/_IG-REQUESTS/’ libxcb.so.1*

-=======================================-
METHOD 2: COPR REPOSITORY VERSION OF ATOM

wget https://copr-be.cloud.fedoraproject.org/results/alonid/yum-plugin-copr/epel-7-x86_64/00110045-yum-plugin-copr/yum-plugin-copr-1.1.31-508.el7.centos.noarch.rpm
rpm -ivh yum-plugin-copr-1.1.31-508.el7.centos.noarch.rpm
yum copr enable helber/atom
yum update
yum install atom
yum install libxcb.x86_64
cp /usr/lib64/libxcb.so.1* /usr/share/atom/
cd /usr/share/atom/
sed -i ‘s/BIG-REQUESTS/_IG-REQUESTS/’ libxcb.so.1*
-=======================================-

HOWTO INSTALL X2GO with XFCE on Cento7

#1. Add EPEL repository first.
yum install epel-release

#2. Then, install X2Go server package using command:
yum install fuse-sshfs
yum install x2goserver x2goserver-xsession

#3. Install XFCE Desktop
yum -y groupinstall “Xfce”
-=======================================-

Hope this helps!