Ignored names still show in tree view


#1

Well pretty much what says on the title. Ignored names like .git shows in tree view, maybe is made like that on purpose but it would be nice to be able to hide it.


Exclude certain files from Tree View ignore
.gitignored files are hidden from tree view regardless of setting
Can't undo .gitignore effects
#2

This is already possible, though the setting is a little bit hidden. Open up the preferences with cmd-, and then scroll down to the settings for the Tree View package. You’ll see “Hide Ignored Names” and “Hide Vcs Ignored Files” options. Those should do what you’re looking for!


#3

Thanks a lot. I think I must get used to the modular nature of Atom. Lovely tool :smiley:


#4

or if you want you can always theme it out …

.tree-view {
  .status-ignored {
    display: none;
  }
}

#5

Does the ignore setting accept wildcards? E.g. I tried the above and added ._* which often works for other editors, but still see a lot of files in my tree prefixed with ._


#6

It doesn’t look like it:

But that’s probably fairly easily fixed. Pull requests accepted!


#7

Thanks so much for pointing that out. It would be great if that was checked by default, as otherewise it is confusing for me: what on earth is the very prominent “ignoredNames” configuration field for? If it requires this secretive option to be enabled for it to work… It may be for something else, but it is unclear, making this situation highly unintuitive.


#8

Is it now possible to hide all dot files (.*) in tree view without write each filename in the hidden list? I would like to hide all hidden files in tree view.

Another feature which would be great is to exclude a path from the hidden list, for example I hide all dot files, but I would like to see one special hidden file.


#9

Potentially very helpful (though I am puzzled why this is not the default and what “Ignored Names” is supposed to do if not hide names from the sidebar).

However, it’s not working for me. I have Ignored Names = .git, .svn, .DS_Store, .pyc
and the Tree View settings you mention ARE checked and I still see .pyc files.

I’ve tried changing IgnoredNames and .git, .svn, .DS_Store all work as expected; only .pyc is being ignored. I’ve tried retyping it, but it makes no difference. I’m really puzzled.

Just for fun, I tried hiding all .py files and all .h files and neither of those worked, either. It acts as if something is overriding it (which might make sense for .h and .py, but why .pyc?)


#10

.git, .svn, and .DS_Store are all full file names. .pyc, .h and .py are not. *.pyc will achieve what you’re trying to do.


#11

Thank you. That did it.


#12

@balupton did you ever get to the bottom of this? As far as I can tell the “Ingored Names” list under settings doesn’t affect the tree view. Is this the intended behavior?


#13

It is the expected behavior if Hide Ignored Names is unchecked in the Tree View settings page:


How to hide .DS_Store files in the tree view?
#14

Thanks @leedohm. When that’s not checked, what does “Ignored Names” do?


#15

I know that it currently affects the fuzzy-finder package, for example the fuzzy-finder:find-file command (Cmd+T on OS X). A more full description of the interactions can be found in a StackOverflow answer I wrote here:


#16

I moved 3 posts to a new topic: Ignored files not showing when opening a descendant folder of Git root


#17

thank you sir!


#18

vcs ignore? what’s vcs? anyways, seems cryptig. too cryptic for me, that i didn’t recognize it. i strongly suggest to add details to that desciption


#19

vcs is a pretty common acronym for Version Control System.


#20

Okay All, I’ve figured this out! I have .git (the folder), .gitattributes & .gitignore

In Settings, this is what I have for ignored names:

Then, I go into the Packages, and find the TreeView Settings
Finally, I check the box, to hide ignored names, and save all. The Tree View now hides my GitHub files.

I hope this helps everyone who struggled with these settings.