Ignored files not showing when opening a descendant folder of Git root


#1

When will this bug be fixed?

With the setting for files to be ignored, they still show up, only some* are hidden. Even tho they clearly show as ignored in the editor.


Ignored names still show in tree view
#2

To which bug are you referring? Do you have a link?


#3

“Ignored names still show in tree view”

^ with all the settings people refer to, ignored files still show in the tree view.

If your tree is:

root
-> src
----> site
---------> js

The ignore file exists in root, but you open atom folder from site, all files/folders that are ignored in the gitignore in root show. But if you open from root, they hide correctly.

Yet from the site level atom correctly knows that files are modified or not in git. So it has knowledge of what is tracked in git, it should also acknowledge what is ignored.

This is a bug.


#4

Last I checked, if you open a folder that is deeper than the Git root, you don’t get any of the Git features including modified status. I’ll double-check when I get home.

Regardless, would you mind opening a bug on the tree-view package for this?


#5

I could not reproduce the issue you’re describing by following these steps on v0.124.0-dda0e7f of Atom:

Repro Steps

  1. Clone the Atom repository
  2. Execute the command mkdir -p spec/fixtures/evil-files
  3. Execute the command touch spec/fixtures/evil-files/foo.test
  4. Execute the command cd spec
  5. Open Atom using the command: atom .

Expected and Actual: The fixtures/evil-files folder is grayed out, hidden or not depending on your settings

Which version of Atom are you using? From where did you install it?


#6

Using latest version from atom.io website, downloaded 4 days ago.

I donno how you can not reproduce it, I just downloaded Atom here at work.

Created 4 folders. Git init on the root, added a .gitignore, ignored all *.js files, added a bunch of js files.

Open Folder at the 4th folder containing the .js files, changed the settings. Files still show, closed/re-open, files still show.

Open Folder from root, files do not show.


#7

All I can say is what I’m seeing. You said you created four folders. Are they nested one inside each other? Or are they all at the same level? Or is it some mix? Or is it the format you show in your previous post above? (Sorry, missed that detail … it’s getting late here.)

Can you give me the specific version number? You say four days, but depending on your time zone and the time when you downloaded it, that could be v0.121.0, v0.122.0 or v0.123.0.

Details like these are vitally important when trying to reproduce a bug. (Hence my very specific format when I’m reporting steps to reproduce behavior.) The more details you can give, the better. I’m not just doing it to make work for you :grinning:

What do you have the following settings set to?

  • tree-view.hideIgnoredNames
  • tree-view.hideVcsIgnoredFiles

#8

I have v0.122.0.

Yes nested folders.

From the root:

From the sub directory:

Changing the settings doesn’t matter. Results are the same.


#9

Also I understand you’re trying to help and being patient, I just don’t know what more to give you… I thought I was being clear. :smile:


#10

Ok, I’ve reproduced the bug:

Repro Steps

  1. Clone the Atom repository
  2. Execute the command mkdir -p spec/fixtures/evil-files
  3. Execute the command touch spec/fixtures/evil-files/foo.test
  4. Launch Atom using the command atom . from the root of the Atom repository
  5. Set tree-view.hideVcsIgnoredFiles to true
  6. Verify that in the tree view the path spec/fixtures/evil-files does not show
  7. Exit Atom
  8. Execute the command cd spec/fixtures
  9. Open Atom using the command: atom .

Expected: The evil-files folder should not be visible
Actual: The evil-files folder is visible, but grayed out, indicating it is recognized as a VCS Ignored path

I’ve filed atom/tree-view#203.


#11

WOOOHOOO Success. :slight_smile: thanks.


#12

Response from @kevinsawicki:

This was explicitly added in atom/tree-view#9

The thought behind it behind being: opening an ignored subfolder with this option enabled would cause the tree view to be completely empty which is probably not what the person wants and would be confusing.

I’m up for revisiting it though if anyone has ideas on how to present this case better.

I don’t have any better suggestions so I’ve closed the Issue for now. Feel free to add your thoughts directly on the bug.