If I press shift+> the Developer Tools will open


#1

Hello,
sometimes if I press shift+> it open the “Developer Tools” in Atom.
I don#t understand whats wrong with it. In the Keybindings there is no corresponding binding.

Does somebody can repeat this?

BR


#2

Are you using an International keyboard? Or Dvorak+Qwerty setting?


#3

Hi,
I’m on a Macbook Pro with an QWERTZ (Germany) keyboard.


#4

Don’t the developer tools pop up whenever atom encounters an error which gets logged to the console?
Are there any errors logged there?


#5

Can you use the Keybinding Resolver Cmd+. to determine what keys Atom thinks you’re typing? Atom has some issues with international keyboards right now:


#6

Hi,
the Key Binding Resolver shows me >. And the Console shows me this error:

Window load time: 7962ms /Applications/Webentwicklung:Programmierung/Atom.app/Contents/Resources/app/src/window-bootstrap.js:18 Cannot find module 'atom' Error: Cannot find module 'atom' at Function.Module._resolveFilename (module.js:337:15) at Function.Module._load (module.js:279:25) at Module.require (module.js:363:17) at require (module.js:379:17) at Object.<anonymous> (/Applications/Webentwicklung:Programmierung/Atom.app/Contents/Resources/app/node_modules/fuzzy-finder/lib/load-paths-handler.js:10:9) at Object.<anonymous> (/Applications/Webentwicklung:Programmierung/Atom.app/Contents/Resources/app/node_modules/fuzzy-finder/lib/load-paths-handler.js:134:4) at Module._compile (module.js:455:26) at Object.Module._extensions..js (module.js:473:10) at Module.load (/Applications/Webentwicklung:Programmierung/Atom.app/Contents/Resources/app/node_modules/coffee-script/lib/coffee-script/register.js:45:36) at Function.Module._load (module.js:311:12) at Module.require (module.js:363:17) at require (module.js:379:17) at Object.<anonymous> (/Applications/Webentwicklung:Programmierung/Atom.app/Contents/Resources/app/src/task-bootstrap.js:95:13) at Object.<anonymous> (/Applications/Webentwicklung:Programmierung/Atom.app/Contents/Resources/app/src/task-bootstrap.js:97:4) at Module._compile (module.js:455:26) at Object.Module._extensions..js (module.js:473:10) at Module.load (/Applications/Webentwicklung:Programmierung/Atom.app/Contents/Resources/app/node_modules/coffee-script/lib/coffee-script/register.js:45:36) at Function.Module._load (module.js:311:12) at Module.require (module.js:363:17) at require (module.js:379:17) at [eval]:3:1 at Object.exports.runInThisContext (vm.js:70:17) at Object.<anonymous> ([eval]-wrapper:6:22) at Module._compile (module.js:455:26) at evalScript (node.js:658:25) at startup (node.js:90:7) at node.js:1037:3 /Applications/Webentwicklung:Programmierung/Atom.app/Contents/Resources/app/src/task.js:52 Cannot call method 'bind' of null TypeError: Cannot call method 'bind' of null at process.<anonymous> (/Applications/Webentwicklung:Programmierung/Atom.app/Contents/Resources/app/src/task-bootstrap.js:82:24) at process.EventEmitter.emit (events.js:104:17) at handleMessage (child_process.js:318:10) at Pipe.channel.onread (child_process.js:346:11)


#7

What I suspect is happening is things are choking on the colon, :, in the file path: /Applications/Webentwicklung:Programmierung/Atom.app/Contents/Resources/app/src/window-bootstrap.js

Is it possible for you to move Atom.app to a path that doesn’t have a colon in it?


#8

Hi,
sorry for my late reply.
I changed the foldername to “webentwicklung” but an error is still existing:

Window load time: 2750ms /Applications/Webentwicklung/Atom.app/Contents/Resources/app/src/window-bootstrap.js:18

Uncaught InvalidCharacterError: The string contains invalid characters. /Applications/Webentwicklung/Atom.app/Contents/Resources/app/node_modules/text-buffer/lib/history.js:99

Now it is different but it is furthermore if I press > after ?.

BR


#9

I have this problem too and it’s making Atom unusable for me.

In multiple Rails projects, I find this happens most in the application.html.erb file, when I go to close an erb tag with %>, typing the > (shift + >) brings up the Atom JS console with this error:

Uncaught InvalidCharacterError: The string contains invalid characters. /Applications/Atom.app/Contents/Resources/app/node_modules/text-buffer/lib/history.js:99

I notice that Atom suggests the file type as HTML while it recognizes other erb files as HTML (Rails). I’ve tried changing the file type to HTML (Rails) to see if that would solve this but it doesn’t.


#10

Can either of you reproduce this error when running Atom using atom --safe?

Have you followed the steps in the Debugging Guide?


#11

I did all you said, the error appears when the package Autoclose Html is activated, I have Atom 0.108.0 and file html.erb


#12

Sounds like the bug is with the Autoclose HTML package then?


#13

Ah, yep. That fixed it for me. Disabled that sucker. I’ll file an issue with them.

Thanks!


#14

Si, with atom --safe no problem.


#15

Are you using Autoclose HTML also?


#16

Yes, when Autoclose Html is active, the error appears.


#17

Hello,
yes I’m using Autoclose HTML also.
After disabling the error disappears. Thanks.

I postet an bugreport in Github: https://github.com/mattberkowitz/autoclose-html/issues/13


#18

You’re welcome … I’m glad that we could collectively figure out what was the issue :grinning:


#19

Hi,
after I report the bug in Github, mattberkowitz has published the version 0.6.0 of the Autoclose HTML package.
Actually I have only do a little test and no error occurred. Hopefully it is solve :).