IDE-PHP language server stopped unexpectedly


#1

Hi,
I install the atom ide and the php-ide language and when I open a project, open a .php file the editor froze and force close. When I relaunch it I have the following error :

PHP Warning: require(/home/nathan/.atom/packages/ide-php/vendor/composer/../symfony/polyfill-mbstring/bootstrap.php): failed to open stream: No such file or directory in /home/nathan/.atom/packages/ide-php/vendor/composer/autoload_real.php on line 66 PHP Fatal error: require(): Failed opening required '/home/nathan/.atom/packages/ide-php/vendor/composer/../symfony/polyfill-mbstring/bootstrap.php' (include_path='.:/usr/share/php') in /home/nathan/.atom/packages/ide-php/vendor/composer/autoload_real.php on line 66

Did I miss something ?

Thanks in advance


#2

Have the same issue. Anyone knows what the solution is?


#3

Did you just install ide-php, or has it worked previously? What OSes are each of you running?


#4

Hi,
For me the solution was to uninstall ide-php via Atom directly and then reinstall it via Atom also and no error again


#5

I did that, opened a new terminal and it worked from there. Thank you!