IDE packages - version mismatch errors


I installed the atom-ide-ui successfully, then set off to install ide-typescript, ide-java and ide-php.

ide-java and ide-php give me the following error:

There’s no version of this package that is compatible with your Atom version. The version must satisfy >=1.21.0.

ide-typescript tells me:

Version 0.1.6 is not the latest version version available of this package, but it’s the latest that is compatible with your version of Atom.

A version check of Atom tells me that 1.20.0 x64 is the latest version.

Did I miss something that IDE functionality is out, but is dependent on an upcoming update of Atom?


As discussed in the blog post, those packages are being built for the current beta version, 1.21.0.


Oh man, I can’t read. I was so happy to see IDE functionality that I totally glossed over that part. Thanks!