I want Ctrl-Tab to work like it used to. How do I do that?


#1

In Atom 1.14 or later

An option was added to the tabs package in Atom 1.14 to restore the original behavior:

  1. Launch Atom
  2. Open the Settings View using Cmd+, on macOS or Ctrl+, on other platforms
  3. Click the Packages tab
  4. Search for “tabs”
  5. Click the Settings button on the tabs package card
  6. Uncheck “Enable MRU Tab Switching”

In earlier versions

Add the following to your keymap.cson:

'body':
  'ctrl-tab ^ctrl': 'unset!'
  'ctrl-tab': 'pane:show-next-item'
  'ctrl-shift-tab ^ctrl': 'unset!'
  'ctrl-shift-tab': 'pane:show-previous-item'

Keyboard shortcut for cycling through tabs
Change Tab Switching Order back to Linear
Ctrl-tab key mapping on Windows
How to fix crazy tab navigation order?
Disable default keybindings
Keyborad remap issue with Atom
Custom keybindings only work halfway
Disable default keybindings
Tab scrolling
Deactivate new tab switcher