I need a little help with the "script" packages


#1

so i have the script packages installed and when i press ctrl shift B i get this error

‘javac’ is not recognized as an internal or external command,
operable program or batch file.

and i have javac installed but i dont know what to do with it


#2

What happens when you try to use javac from the command line? If you get the same error, then it is not in your PATH and you need to add it.


#4

What operating system are you running?


#5

windows

this is needed for the character limit


#6

That is not a sufficient answer. Different versions of Windows do things differently.


#7

oh
windows 8 x86


#8

Press the Windows key and x to pull up a menu. One of the items on that menu is Command Prompt. Click on it and a command line window will open. Type javac into the window and see what the answer is.


#9

javac is not recognized as an internal or external command
operable program or hatch file

thats what popt up


#10

i just looked thru my downloads and it´s saying the file has been moved or missing let me redownload it


#11

Please put compiler executables somewhere other than your Downloads folder.


#12

have done but still shows the same error


#13

You need to add the folder where the executable is to your PATH as you can see in the link I posted in my first reply.


#14

ok i did what was on the website and made path to the where the javac file is

C:\Program Files (x86)\Java\jdk1.8.0_121\bin

still gives the same error what did i do wrong or what is wrong


#15

You need to restart Atom in order for it to pick up the new PATH variable (same for the Command Prompt window).


#16

so on a level of stupidity 1-20 im on 21 i forgot to save the path :sweat:
but it works better now it shows a lits of “stuff” in the command prompt and the error in atom has changed
javac: file not found: someone.java
Usage: javac
use -help for a list of possible options


#17

What stuff?

the error in atom has changed
javac: file not found: someone.java

Is this the file you’re trying to compile with script?


#18

-g
-g:none
-g:lines,vers,sourse
commands like that

what do you mean with [quote=“DamnedScholar, post:17, topic:39766”]
Is this the file you’re trying to compile with script?
[/quote]

if you mean if i have code in there yes i do
if you mean am i trying to run the code with script yes i am
if not the above please what do you mean
(again, noob sorry)


#19

This is not particularly important right here, but it addresses an issue in your posts above: you can and should copy/paste or screenshot any output we request so that we can see exactly what it says. Lazily retyping the output when you don’t understand what it means has the potential to lead to people who are trying to help you not have the correct information.

please what do you mean

You posted an error message that mentioned a file called someone.java. Is that the name of the file you’re trying to compile? What is the path to the directory that the file is in?


#20

In the Script package settings, change “Default CWD Behavior” to “Directory of the script” and see if that helps.