I just packaged my app with electron-packager


#1

How do I now run my app? When I double click on the app icon I get this error:


Could Not Display “eQuicky”

There is no application installed for “executable” files.
Do you want to search for an application to open this file?


#2

Did you find a solution for this? What was the issue?


#3

no I haven’t. I held off from packaging for now. I will return to this process when my app is finished.


#4

Ok. I was able to find out the issue in my case. When packaging the app with electron-packager, I was specifying the out parameter. The location I was specifying in the out parameter ‘/media/shashi/data/’ was on a partition which is shared with Windows. On this partition, when the files are copied by the packager, they do not seem to have the correct permissions. Thus, the executable file does not have the permissions to execute. Interestingly, I was not able to change the permissions on these files using sudo chmod. I don’t yet know why. I just happened to discover this because unpacking Visual Studio Code on the same partition also threw the same error. So I checked for permissions using ls -l and saw that the requisite permissions were not given.

When I changed the out location to my primary partition, the files were created with the correct permissions and the executable worked as expected.