I had all my keybindings lost for tree-view package. How to resurrect them?


#1

I had a strange thing happen. All my keybindings relating to the tree-view package stopped working. They’re not showing up in the key binding resolver either. I have no idea what to do. I tried disabling all packages, rebooting my computer, redownloading atom, disabling and reenabling the tree-view package. Still it’s not working. Everything else works fine just as usual.

Any ideas? I’d be very grateful…


#2

There is a button in the tree-view settings that turns off all keybindings. Is that set?


#3

Hmm, I don’t see such setting. Here’s what my tree-view settings page looks like:


#4

Scroll down to the keybindings.


#5

What do you mean? There are no more settings there.

Here is the full page of the tree-view settings:


#6

Weird. You are missing the keybindings section.

You may have already tried this but …

  1. close all atom windows
  2. remove or rename ~/.atom
  3. restart atom

If that doesn’t work do it again with a reinstall between steps 2 and 3.

If that doesn’t work post an issue on the tree-view repo.


#7

Thanks a lot. Removing ~/.atom folder worked — the tree-view responded to keybindings again.

So although i tried to find something in the ~/.atom settings before, i now searched again. And found this eloquent statement:

packagesWithKeymapsDisabled [
    "tree-view"
]

So there’s even a corresponding option in the atom Core Settings: “Packages With Keymaps Disabled”.

Removed tree-view from there, now it’s fine.
I don’t really want to say this, but I really “have no idea how it got there” :slight_smile:

Thanks a lot for your help!


#8

I had this happen today to me after I disabled Key Bindings setting in tree-view cor pkg, then quit out of Atom. When I reopened Atom and went to the tree-view package settings, the Key Bindings were gone! Seems this is not proper behavior. Key Bindings section should still be there but showing the disabled state as set, not make the section disappear.


#9

@cfcoder Correct, what you’re experiencing is a bug (https://github.com/atom/settings-view/issues/946). As a workaround, open your config.cson, where there should be a packagesWithKeymapsDisabled section (or similar). Delete tree-view under that section to re-enable keybindings.


#10

I used the Atom UI in Atom > Preferences > Core Settings to remove the package name from Packages With Keymaps Disabled input. A fix for the bug should prevent that from happening.
Thanks for responding Wilu.