I can't use the Git Plus package


#1

I’m trying to use this package to do a push in my repository, but I have a problem with the Git Path, I’ve copy the URL of my repository and paste it, but it doesn’t work. Atom shows me this error: “The file name, the directory name or the volume label syntax isn’t correct”.


#2

It sounds as if you entered the path of your git repo, but what they want is the directory where the git executable is.

If that wasn’t it, please provide more details: Which operating system are you using? Which version of Atom? Screenshot of where you pasted the path? What’s at that directory?


#3

There’s a screenshot. My OS is Windows 8.1 Pro Edition x64, Atom Version: 0.204.0


#4

Yes, the “Git Path” setting is wrong. It wants to know the path to your git.exe. For example:

C:\Program Files\Git\bin\git.exe

I have no idea what’s the correct value, but at least you have a hint. If you can run git from the command line without having to specify the full path, then maybe you don’t even need to change the default value of that setting.


#5

Actually, if your git is already in your path (i.e. you can execute git commands from any command window), you should probably be able to leave this field blank.


#6

Yes, now it works. Thank you very much.


#7

Thank you!