I cant update any of my package?


#1

i can update any of my package and i have no idea why , here is one of the failure update error code , could you guys help me about it ?

Project
Settings
Core
Editor
System
Keybindings
Packages
Themes
Updates
Install
Open Config Folder
Available Updates

Check for UpdatesUpdate All
Updating to “file-icons@2.1.15” failed.Hide output…

npm ERR! Windows_NT 10.0.16299
npm ERR! argv "C:\\Users\\_monster\\AppData\\Local\\atom\\app-1.21.1\\resources\\app\\apm\\bin\\node.exe" "C:\\Users\\_monster\\AppData\\Local\\atom\\app-1.21.1\\resources\\app\\apm\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "C:\\Users\\_monster\\.atom\\.apm\\.apmrc" "--userconfig" "C:\\Users\\_monster\\.atom\\.apmrc" "install" "C:\\Users\\_monster\\AppData\\Local\\Temp\\d-118221-4920-1a3g3rg.otp3545cdi\\package.tgz" "--runtime=electron" "--target=1.6.15" "--arch=x64" "--global-style"
npm ERR! node v6.9.5
npm ERR! npm  v3.10.10
npm ERR! path C:\Users\_monster\.atom\.apm\alhadis.utils\0.1.2\package.tgz.315086472
npm ERR! code EPERM
npm ERR! errno -4048
npm ERR! syscall rename

npm ERR! Error: EPERM: operation not permitted, rename 'C:\Users\_monster\.atom\.apm\alhadis.utils\0.1.2\package.tgz.315086472' -> 'C:\Users\_monster\.atom\.apm\alhadis.utils\0.1.2\package.tgz'
npm ERR!     at Error (native)
npm ERR!  { Error: EPERM: operation not permitted, rename 'C:\Users\_monster\.atom\.apm\alhadis.utils\0.1.2\package.tgz.315086472' -> 'C:\Users\_monster\.atom\.apm\alhadis.utils\0.1.2\package.tgz'
npm ERR!     at Error (native)
npm ERR!   errno: -4048,
npm ERR!   code: 'EPERM',
npm ERR!   syscall: 'rename',
npm ERR!   path: 'C:\\Users\\_monster\\.atom\\.apm\\alhadis.utils\\0.1.2\\package.tgz.315086472',
npm ERR!   dest: 'C:\\Users\\_monster\\.atom\\.apm\\alhadis.utils\\0.1.2\\package.tgz',
npm ERR!   parent: 'file-icons' }
npm ERR! 
npm ERR! Please try running this command again as root/Administrator.

npm ERR! Please include the following file with any support request:
npm ERR!     C:\Users\_monster\AppData\Local\Temp\apm-install-dir-118221-4920-wjuctx.t7bsr79zfr\npm-debug.log

23,312
aligner-php 1.1.1PHP support for aligner
adrianlee44
Update to 1.2.0SettingsUninstallDisable
4,386,281
atom-beautify 0.30.5Beautify HTML, CSS, JavaScript, PHP, Python, Ruby, Java, C, C++, C#, Objective-C, CoffeeScript, TypeScript, Coldfusion, SQL, and more in Atom
Glavin001
Update to 0.32.2SettingsUninstallDisable
51,011
atom-css-clean 2.23.0A package for sorting and aligning CSS and SASS.
SeanJM
Update to 2.24.1UninstallDisable
204,254
atom-live-server 2.1.2Launch a http server with live reload capability.
jas-chen
Update to 2.2.0UninstallDisable
1,321,559
atom-material-ui 2.0.4A dynamic UI theme for Atom that follows Google's Material Design Guidelines
atom-material
Update to 2.1.3SettingsUninstall
4,377,182
file-icons 2.1.11Assign file extension icons and colours for improved visual grepping
file-icons
Update to 2.1.15SettingsUninstallDisable
15,451
filesize 3.0.0Displays the current file's size on the status bar
mkxml
Update to 4.0.0SettingsUninstallDisable
1,911,548
git-plus 7.9.3Do git things without the terminal
akonwi
Update to 7.10.2UninstallEnable
350,818
linter-htmlhint 1.3.3A plugin for Atom Linter providing an interface to HTMLHint.
AtomLinter
Update to 1.4.0UninstallEnable
683,850
linter-jshint 3.1.5Linter plugin for JavaScript, using jshint
AtomLinter
Update to 3.1.6UninstallEnable
196,803
linter-sass-lint 1.7.6Atom Linter plugin to lint your Sass/SCSS with pure node sass-lint
AtomLinter
Update to 1.8.3UninstallEnable
102,295
minimap-linter 2.0.2Minimap display for Linter messages
AtomLinter
Update to 2.1.3UninstallEnable
1,038,021
platformio-ide-terminal 2.6.0A terminal package for Atom, complete with themes, API and more for PlatformIO IDE. Fork of terminal-plus.
platformio
Update to 2.8.1SettingsUninstallDisable
1,270
quick-file-actions 0.2.1Quickly copy, delete, move, and create new files.
filipesabella
Update to 0.2.2SettingsUninstallDisable
92,116
sass-autocompile 0.13.3Automatically compiles SASS files on save.
armin-pfaeffle
Update to 0.13.5SettingsUninstallDisable
136,070
set-syntax 0.3.2Creates easy Command Palette commands for setting the syntax of the current file
lee-dohm
Update to 0.4.0UninstallDisable
76,663
wakatime 7.0.3Fitbit for programmers. Get automated metrics and insights about your programming.
wakatime
Update to 7.0.4SettingsUninstallDisable
Settings
0 files17 updates (1 failed)

#2

Try deleting the folder C:\Users\_monster\.atom\.apm\, restart Atom, and try again.

If that doesn’t work, you can rename the .atom\ folder and restart Atom (to make a blank .atom\ folder), then copy packages\ and your config files back, restart Atom again (to pick up all of your settings and packages), and see if the packages update.

Have you ever run Atom as Administrator? Did you maybe run the installer as Administrator?


#3

Thanks you so much DammedScholar it worked


#4

No problem. :slight_smile:


#5

I’m currently having this problem suddenly.

Try deleting the folder C:\Users_monster.atom.apm, restart Atom, and try again.

Deleted everything inside of .atom Still no dice.

Uninstalled / Re-installed. Still no dice.

Have you ever run Atom as Administrator?
Yup, no dice.

Any other thoughts?


#6

@erwstout - for completeness, can you share what version of Atom you’re running and the output you get when updating/installing a package?