I can't type in the IDE


#1

This is freaking me out… I have Atom’s latest version and for some reason most of the times I can’t type… I have to randomly type things, some lines get erased and only then i can write code normally… I’m a Mac OS user, used to Sublime Text. Anyone has this problem already? What the heck is causing this?
Thank you!


#2

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#3

I’m using Atom’s latest versions - 0.135.0 - on Mac OS Mavericks 10.9.4.

I’m not understading how to run the “atom --safe” command. Could you please explain it to me?


#4

Initial Setup

  1. Launch Atom normally
  2. Pull down the Atom menu
  3. Select Install Shell Commands from the menu

Launching in Safe Mode

  1. Open Terminal from Launchpad
  2. Type the command atom --safe and press ENTER

See the Safe Mode documentation for a little more information.


#5

The Best solution to this is to uninstall Vim Mode if that was installed. I do not like the safe mode because some of the syntax highlighting for some languages failed to be implemented.


#6

Not sure if any of you have found a solution to this but I keep running into the same issue where I can no longer type anything in Atom. This includes even Atom’s own settings screens. No input works anywhere. Only command mode works (moving around the file, changing words/characters, deleting, etc but nothing can be typed in insert mode. When it triggers, the problem is isolated only to that individual Atom window. The other windows are unaffected until I switch to them and do whatever it is that triggers this. The only way to fix it is for me to quite Atom and re-open it. Luckily, Atom saves all open windows and tabs so it restores my env; however, this issue happens so often now that Atom has become entirely unusable for me and I’ve resorted back to the tried and testing vim.

This was happening to me before the official 1.0 release of Atom so I stopped using it for a while and when I came back to upgrade Atom and all my extensions, it started working without any issues again… until just last night for me. It’s funny because I hadn’t actually installed or changed anything at all and it had been working without issues for at least a few weeks then, out of the blue, last night the issue started up again. I’ve since disabled/uninstalled all sorts of extensions such as linters, autocompletions, etc but the plugin that, when disabled/uninstalled, fixed this was the vim-mode plugin itself.

I think I may have pinpointed what triggers this for me. Essentially, whenever I went into visual mode, selected some text and then either pasted from the clipboard or just hit ‘c’ to change the text, I wouldn’t be able to type anything into the editor anymore. I’ve tried all sorts of this to get out of this crappy limbo state but the only way is to restart Atom and wait for it to happen again.

Funny thing, after uninstalling a handful of extensions last night, I was able to prevent this from happening when editing Django HTML files. In my other window, which is full of a whole bunch of LESS file tabs, it’s still happening. I wonder if certain filetype specific plugins are triggering this. I just haven’t been able to pinpoint it that specifically yet.

I would absolutely LOVE some help trying to get rid of this problem for good. It’s absolutely crushing my Atom experience. There’s a whole lot of us out there that depend on VIM so using Atom without it is a showstopper for me. Figuring this out should certainly be a priority considering the shear number of vim-mode users. I’m happy to help provide whatever log data, screencasts/shots, etc may be needed to debug and get to the bottom of this.

Thanks in advance for any help on this!


#7

You should post an Issue on the vim-mode package. If you have a 100% repro, you should post detailed instructions on how to make it happen. When you do post an ssue there, please post a link to it on this topic.


#8

This really sounds like you’re using vim-mode without knowing it.

Typing randomly with vim-mode enabled will make you issue commands like x (cut/delete), etc. until you press i or something similar which puts you into insert-mode, where you can type normally.


#9

:slight_smile: I really wish that was the case but, trust me, I’m not in VIM mode. I’m an avid VIM user with a vimrc I’ve built out over the 10+ years I’ve used it… I’m definitely not in VIM mode (fat cursor). When my ATOM locks while editing, it’s in insert mode (thin cursor). I’ve tried fixing it using all of the mode change commands to no avail.


#10

I should also add that my keyboard isn’t just not working for that one editor tab, it’s busted for the whole ATOM window. I can’t even type into any of the ATOM editor settings/preference pages.


#11

Good call, I’ll go do that now.


#12

Not sure if it’s related to your issue, but that’s how I solved it in my case:
I have the “tree-view” plugin installed and noticed that any key that I’m pressing in a text window only affected the tree-view and didn’t show the input text in the editor window. So I looked up the “tree-view” settings and disabled the “Key bindings” checkbox and then enabled it again. This did the trick for me and I can now edit the text files again.


#13

Having the same issue now after upgrading to 1.17.2. It’s also due to Tree View, “Auto Reveal” feature basically keeps focusing/activating the tree view. Disabling that fixed it for me.


#14

I had the same issue (no cursor in the file-edit panels and therefor no way to type) on Kubuntu (4.16) and Atom version 1.19.7 x64. I “fixed” it by disabling the “Focus On Reveal” option of the “tree-view” package (0.217.2).
(“Auto Reveal” works fine, so i’m using that one now.)


#15

This must have been my problem - this solution worked for me!


#16

Nevermind! Its still broken. Unfortunately Ive lost a lot more productivity with atom than Ive gained in the last year. I was able to type for a bit, then when I reloaded atom I lost ability to type anything anywhere again. Cant afford to be troubleshooting problems in my IDE on a regular basis. Its a great idea in theory, but “not ready for production.”

Ill check back in a few years and see how atom is doing :wink: