I can't install packages or themes on my atom


#1

When I try to research some package or Theme on Atom, it always shows to me this message above. I’ve tried somethings but I’m new here and don’t know how to use the application. Thanks for helping.


#2

What happens if you open a command line window and type apm config set strict-ssl false?


#3

Hi, I don’t know where I can do that. But I did this in different tabs: in “init.coffee” and “Untitled”.
I write every thing you said and nothing happens. Just in the “init.coffee” words change the colors.

Am I doing it right? How do I run the code? Thanks for helping.


#4


#5

I don’t either, because you haven’t shared your operating system with me, but “a command line window” generally refers to a window for the command line built into your computer.


#6

Oh, OK! I use Windows 10 64x. So, I will try to do it now.

I’ve tried and I got this message:
atom%20pro3

As I you see ‘apm’ is an unknown internal or external command, an app or a batch file.


#7

Okay, you’re going to need to go into Windows’ settings, open your environment variables, and add two entries to your PATH:

C:\Users\lazar\AppData\Local\atom
C:\Users\lazar\AppData\Local\atom\bin

Close and reopen the Prompt de Comando window and try apm config set strict-ssl false again.


#8

I did every thing you said and I got the same result:
atom%20pro4


#9

Check inside AppData/Local/atom/ to make sure that there’s a bin/ folder with four files in it. If not, follow these instructions to create one and that should fix your problem.


#10

In fact, there wasn’t a folder ‘bin/’. I’ve followed all yours instruction but the problem still unsolved. I compered my ‘atom’ folder with an image in that discuss and I saw a difference between their. Look:

It’s different!


#11

Where is Atom installed?


#12

Hey!

There are 2 folders: at C:\users\lazar\AppData\Roaming\Atom and another at C:\Users\lazar\AppData\Local\atom.

Thanks for helping.