I can't hide invisibles


#1

I can’t get invisible characters (spaces, linebreaks, etc) to go invisible.

I toggle the ‘Show Invisibles’ checkbox in Editor Settings on and off and nothing changes in any of my views - invisibles are always shown.

I’ve tried several themes, including Atom Light, and the invisibles are always visible.

I feel I must have missed something obvious that’s causing this, but I can’t work out what it is.

I’ve tried disabling all the Community Packages I’ve installed. I’m on Atom 1.23.3 on a Mac.


#2

Hmm, I can’t reproduce with Atom 1.23.3 on macOS 10.12.6. Can you reproduce in safe mode (atom --safe)?

Also, can you share a screenshot that shows both the Show Invisibles setting and an example file where the invisibles are still showing so we’re all on the same page?


#3

Ah, in safe mode this doesn’t happen… does that suggest where my problem might lie?

In case a screenshot still helps, from non-safe mode:


#4

Yes. Safe mode disables all community packages and if something doesn’t reproduce in safe mode it is most likely a problem with one of your installed community packages.


#5

It took a while but I’ve narrowed it down to the vim-mode-plus package. If it’s enabled when Atom starts up then ‘Show invisibles’ stops toggling invisibles on/off. Even if you then disable the package, ‘Show invisibles’ no longer works if the package was enabled on startup.

I’ve taken this over to the package’s Issues.

Thanks for your help @Ben3eeE!