I can't disable a package in safe mode


#1

I put a bug in one of my packages that kept atom from starting. So I started Atom in safe mode. When I brought up the settings tab and clicked on Packages I saw my installed packages but when I clicked on a package name nothing happened. Also there was an install button next to each one that makes no sense in safe mode.

I brought up help for APM and to my surprise there is no APM disable command.

I will move my bad package out of my packages directory to work around this but a lot of what I described above doesn’t smell right.


#2

Disabling packages is done in the PackageManager class and that setting is stored in the config.cson, not by apm. As a workaround, you can always add a package name to core.disabledPackages in the config.cson.

You should probably file bugs on the Settings View package for the UI stuff though.