I am Unable to install the Package


#1

Hi …I tried installing mavensmate package on atom IDE.On clicking install nothing happened,just got the button disabled.so i tiried installing manually,so Dowloaded the latest repo…and in that folder I run apm install.I cant see any progress it got stuck on “Installing modules”…No progress coming after this…

P.S:I dont have any administrative privilege.But for my colleagues ,they installed and working…

Thnks in advance


#2

Are you trying to install packages from behind a proxy? If so, you may want to check the instructions in the apm README here:


#3

“apm config set strict-ssl false”

Yeah I tried this also…But still not working…I downloaded the repo and tried installing…Even though its not working


#4

I have the same problem as well and I do have administrative privileges.

I have tried all of the possible combinations for configuring the proxy:

proxy=
http-proxy=
https-proxy=
http_proxy=
https_proxy=

I have also tried having spaces between the = and no spaces. I also tried the proxy in quotes and without quotes. I also tried two different proxies. Finally I also tried the format of “http://username:password@proxy.fqdn:port”

I also tried both with and without strict-ssl=false and that doesn’t work either.

I would have to say there is an issue with not all proxy servers being recognized. It would be great if this could be fixed or at least a workaround available.

Thanks