Huge memory leak recently


#1

I am trying to fing out which package is causing memory leak. After i did Update All Packages , ATOM is leaking huge memory.
I was opening a project with only 6 files and a folder with less then 20 files total. All together < 1 MB (only 2 opened tabs).

But atom is using over 4 GB of RAM.

with --safe atom use 500 MB max .

After a few disabling packages around , it seems that Auto-Complete-Plus or Auto-Complete-Plus-Python-Jedi is causing it.

Any guide to find out where the leak ?


#2

+1 also seeing this issue. I also noticed that the longer atom has been open for, the more total memory that is being used. Even with 16GB of RAM if I have Atom open for long enough I get a popup that says my computer is out of memory, suspends all applications, and forces me to force quit applications before being able to resume normal usage.,


#3

You should submit an issue on that repo.


#4

I know , i want to make sure where it comes from.


#5

Yes , from looking at htop , it jumping about 2-3 mb every 1 seconds.
Then after 30 mins , my linux start swapping.


#6

If you have narrowed it down to those two packages it is likely to be very difficult to determine which package is causing the issue. For example:

  1. If you disable the python-jedi package and the issue goes away, it could be that the memory leak is in the autocomplete-plus package and the python-jedi package is the only thing that exposes it.
  2. If you disable the autocomplete-plus package and the issue goes away, it could be that the only way that the python-jedi package does executes the leaking code is when the autocomplete-plus package is activated.

You should post an issue on the autocomplete-plus-python-jedi package and then work with them to help them narrow it down.


#7

I am looking for tools , and tried to pin point.So Far i’ve tried Running profiler, but it crashed due to insufficient memory LOL.
Ok i will just do that good-old , manual way Thanks.


#8

Do you have atom-complete-plus and auto-complete-plus-python installed?


#9

Seems that auto-complete-plus is causing. opening issue there too.
The memory usage keep increasing altough autocomplete-plus-python-jedi is disabled.
After disabling autocomplete-plus totally , it stopped increasing.


#10

Problem is , there are still alot of ACP Providers i have installed , and i do not have time now to test them all to make sure. If someone in same boat with me , please test and also report here :


#11

yes, not autocomplete-plus-python though. i turned off the “look through all buffers” setting for now and it seems to have helped a little bit.


#12

Seems that HTML or CSS providers are causing it. Disabling them stops Memory increase. ACP itself is fine.