How to use commands from the cmd (shell)


#1

Hi,

I have installed Atom 1.13.0, using Windows 8.1 x64.

I want to install a ftp/remote sync package for editing files on my webspace. But I am getting this error:

In order to solve that I have to follow those instructions, but I don’t know where to type the commands, e.g. npm install npm -g --ca=null. I am trying to write these commands in the Windows’ cmd but it cannot find the command. I also tried it from within these directories:

  • _C:\Users\Israfil\AppData\Local\atom_and
  • C:\Users\Israfil.atom

Where do I have to type these commands?

Thanks.


#2

Btw: Can’t you edit your posts in this discussion?


#3

If you don’t have an npm command, that means that you probably haven’t installed Node. The Node Package Manager is one way that JavaScript developers maintain consistent sets of dependencies throughout their projects and control what libraries they’re using. The Atom Package Manager (apm) is a wrapper on npm and can be used to accomplish many of the same things, but specifically for the purpose of installing Atom’s packages. However, I’m not sure I understand what error you’re getting. Please tell us exactly what happens when you type apm install remote-ftp into your command line.


#4

Hi and thanks. Yesterday I was confused because NO command within cmd (even not the apm command was recognized). Maybe I had to restart Windows. Today the commands are recognized within the shell but It doesn’t work either.
The apm command does not work because of the SELF_SIGNED_CERT_IN_CHAIN. I will fix that. But to do that I need the npm command.
The error messages:


#6

Isn’t there anybody that may help? I have updated node.js but it still doesn’t work.


#7

@leedohm, have you seen this error in connection to package updates?


#8

No, I haven’t seen that error before, at least in connection with Atom package actions. Here’s what the error message means:

  1. In order to have a secure connection between your machine and a web server, it has to be encrypted
  2. In order for it to be encrypted, keys are generated
  3. Keys are validated against certificates
  4. A key is only “trusted” if it is validated against a “trusted certificate”
  5. A certificate is only “trusted” if it is validated against a “trusted certificate authority” or another “trusted certificate”
  6. This means you can have a “certificate chain” that is trusted if it ultimately walks back to a “trusted certificate authority”
  7. There are also “self-signed” certificates, which are certificates that an individual generates that aren’t backed by a certificate authority at all

So the error message is saying that somewhere in the certificate chain that generated the keys for the secure connection is a self-signed certificate which is not trusted, by definition. This typically happens when connecting to a development server (not the case in this case because all of our apm servers are production servers with proper certificates) or there is a proxy server running a self-signed certificate somewhere between your machine and the web server. This second explanation is the most likely cause of the error. Other than trying to connect from another network, I’m not sure I have any suggestions.