How to turn off the line-length marker?


#1

Currently, Atom draws a line at the “Preferred Line Length.”

Is there a way to turn off that line?


Deleting the line in the middle of the editor
#2

You can add this code to your styles.less file

.editor .wrap-guide {
  background: none;
}

#3

In the settings, I’ve put a 0 under ‘Preferred Line Length’, and now I don’t see it anymore.


#4

You can also disable the Wrap Guide package, which is the package that does all of this. This would be my preferred method of disabling the line.


#5

LOL, I double checked in my packages settings, and I have that one disabled, I must have done it at the very beginning (I never use wrap guide in editors) :smiley:


#6

Thanks, @leedohm. I wouldn’t thought to just disable the module. That’s a pretty slick way of modifying one’s editor, now that I think about it.


#7

If I set it to 0, it automatically chnages to 1.


#8

Thanks!! That line was driving me crazy ; )


#9

You can set it to 999, or another width that you’ll never experience.

This might break things that depend on the width being within your experience, though.