How to turn off autoupdate (1.1 crashing, 1.0 works- need to stay on 1.0)


#1

This is very annoying- atom is crashing continuously since I upgraded to 1.1. I’ve found that the last 1.0 release is stable so I want to stay on that but every time I install 1.0 it soon updates itself to 1.1 and starts crashing again. Since 1.1 is unusable for me I need a way to turn off the autoupdate until the crash problem is resolved.

Incidentally it does appear that this 1.1 crashing issue is “known” and a fix has been discovered… the problem appears to be the sheer number of files under a node_modules folder that 1.1 can’t handle. It still annoys me that there’s no way to stay on an older version if you want to not live on the “bleeding edge”.


#2

If you build from source, Atom doesn’t auto-update.


#3

Or if you don’t feel like compiling yourself, I believe autoupdate is also disabled in the .zip release.