How to stop CSS autocomplete from adding the semi-colon (;)?


#1

I’m quite new to Atom, and one thing that’s been bugging me for a while is the automatic addition of the trailing semi-colon when you’ve picked an autocomplete suggestion.

For instance list-style: -> auto-complete -> square puts the semi-colon at the end.

I’ve got 12 years’ muscle memory of typing the semi-colon manually, so I’m frequently & accidentally now writing 2 in a row. It’s also annoying because when there is no auto-complete suggestion, I have to manually type it anyway, so I’d much rather an all or nothing approach.

So, how can I disable it from automatically adding it for CSS, SCSS and LESS?

Thanks


#2

There isn’t an option for this right now. Please file an Issue on https://github.com/atom/autocomplete-css.


#3

OK thanks; will do!