How to stop auto adding of whitespace in atom on save


#1

Hi there,

I work for a company and the application is full of some pretty massive files, I like the auto-linting for my own projects, but when working on a large code base with many other developers and different linting styles, as well as coding styles, linting can sometimes be a nightmare. Especially when looking through a file with thousands of lines of code. It can become very difficult to find the places where the code has actually changed when atom has also decided to clean up thousands of lines of code also.

I have had a good look around but don’t seem to be able to find anything.

Is there a way to turn off auto-linting?

Thanks,

Luke


#2

What package are you using?


#3

Hi DamnedScolar,

Thanks for your reply.

I have not installed any packages for linting that I know of. It is just auto-linting out of the box.

Thanks,

Luke


#4

Atom doesn’t auto lint, unless you referring to spell check?

Does the behaviour occur in safe mode? (open with atom --safe)


#5

Perhaps I am using the incorrect terminology. It basically just removes unwanted whitespace. I have had a look for a whitespace package, and there is one.

It have disabled this and tested it, and it seems to have been this that was causing the issue.

Thank you for your help, I have edited the title to correctly describe the issue I was experiencing


#6

Linters are programs that read your code and report to you about syntactical and stylistic errors.


#7

Okay sure, so it could potentially format code, but I guess in this case it was just a built in atom package. The other devs at my work will be happy :grinning: