How to stop Atom from displacing an open tab when it opens another file


#1

Often i want to open two or more files to compare them, but Atom has a tendency to displace the file i just opened with the other file i then click on, instead of opening both and putting them each in a tab.

I have tried closing a few tabs when this happens, as there are often more open than needed, but it doesn’t seem to help. I can’t figure out how it is deciding when to open a series of files and give each one a tab, and when to close a tab and replace it with another. Maybe it is when i click on two files one soon after the other? At any rate, if i have two panes open and switch between them before requesting the 2nd file, that helps, but only because then something i’m not immediately interested in gets displaced.

I can’t see where to adjust this behaviour. Can i get it to stop doing this? Sometimes it can be convenient, but it is definitely something i’d rather choose to do on occasion, rather than it being done automatically.


#2

This feature is called pending pane items. If you single-click a file to open it, it will open the file as pending and will disappear when you open another file. There are a couple of ways to make a pending tab permanent: 1) double-clicking the file when opening it instead of single-clicking, 2) editing, 3) manually setting it as permanent from the tab’s context menu. See http://flight-manual.atom.io/using-atom/sections/pending-pane-items/ for a full overview of the feature.

However, if you’d rather not have this feature at all, you can disable the “Allow Pending Pane Items” setting in the Settings View.

(Also, there is a FAQ entry on this: I can't open a second file! Opening a second file makes the first disappear!)


#3

Ah, ok. I didn’t think to go to the flight manual. I’ll have to get used to consulting that more.

Thanks :slight_smile: