How to set CXX compilation flags during installation (building from source)


#1

Trying to install atom on RHEL5 computer, no root. After getting all the required lib compiled and installed, the atom building died like:

Error: $mydir/atom.git/apm/node_modules/atom-package-manager/node_modules/git-utils/build/Release/git.node: undefined symbol: __sync_add_and_fetch_4
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/home/ningyu/build/atom/atom.git/apm/node_modules/atom-package-manager/node_modules/git-utils/lib/git.js:8:16)
    at Object.<anonymous> (/home/ningyu/build/atom/atom.git/apm/node_modules/atom-package-manager/node_modules/git-utils/lib/git.js:371:4)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)

Looks like missing some linking parameter during c++ compilation. I don’t have enough knowledge about the building system (coffee script), how can customize linking/compilation parameter during c lib building?

Thanks