How to set Atom engine properly


#1

With the recent upgrade to 1.13, I updated my themes. The previous engine settings looked like this:

"engines": {
    "atom": ">=1.0.0 <2.0.0"
  }

For the updated themes, is it enough to use the following?

"engines": {
    "atom": ">=1.13.0 <2.0.0"
  }

Or do I have to push out one final update for the old versions of those theme using something like >=1.0.0 <1.12.0?


#2

I think you should be fine. I believe the package.json is checked when attempting to update and it’ll compare engine versions.