How to search directories with texts that have more than one line


#1

Hello everyone, everything good ? I recently updated Atom for the latest version and noticed that the publisher now does not search directories with texts that contain more than one line. If I select a snippet of code and press ctrl + f it does not insert the text into the search box and if I try to force it it says it did not find anything. Other old versions of Atom did this, does anyone know how to solve this problem?

Thank you in advance for your help and attention.


#2

You can use line ending characters (\r or \r\n, depending on what mode your file is set to), and regular expressions can easily handle more than one line.


#3

My friend tried it here, but it wasn’t. It’s suggestion works if I fetch it in an already open file. But it doesn’t work when I try to search in a directory of my project. Do you know how to handle it?


#4

If it used to work and doesn’t now, that sounds like a bug.


#5

NOTE: The below answer is not helpful
for the original question and the replies that followed.
I am sorry for the inconvenience caused.
It is helpful for those who are looking for how to make a multi-line search.


Perhaps the regular expression function is not active yet?

@patrickalima98: Please look at the options buttons to follow the idea from @DamnedScholar. Find below a visual indication:
Activate regular expressions

@patrickalima98:
As regular expressions can be tough for someone who does not know it, I have another suggestion:

Editing text inside the search (find) dialog box is a pain otherwise.

Regards.


#6

Hello.

I have more carefully looked at what you asked and what you answered.
You are right. The find for inside projects is a problem for Atom V1.19.5.
There seems to be a problem when line-end character is included.

I am sorry for answering in an unhelpful way (to your problem) earlier.

Below I detail the experiment I have done to prove your position.
The test system is Wondows7 SP1 64-bit with Atom V1.19.5.



CLICK TO SEE A PICTURED STEP-BY-STEP OF EXPERIMENT

1. Get test text

Randomly selected a piece of text in a random file for the test. Note it is line 56.
01_Get test text

2. Check special characters using Python

Copied the test text into the Python Shell to extract the end-of-line character. It is the \n in this case. This text is copied.
02_Check special characters using Python

3. FIND for open editor

Sanity check #1 - use the FIND tool to confirm the correct line is found in the open editor. Note the . is replaced with [.] to make it work in the right way in regular expressions.

4. FIND for active project

No the same text is used in the project find tool. No result is found!

5. FIND for active project but no end line character

Sanity check #2 - the search string is reduced to not include the end-of-line characters. Now line 56 and others come up in the results.



Further tests showed that any search string that includes a \n is a problem. Also Atom V1.20 Beta 4 delivered the same result.

- Dan Padric


#7

Our best friend, since you appreciate for your help and attention :slight_smile: So it’s better that we wait for them to solve the problem? Do you think it’s better to report a Issue to them? Or has another way to do the research in the project in this version. This Utlima version of the Atom you quoted is the one I’m using, so it really gives you this problem :frowning:


#8

Patrick, thank you for the compliment… it is appreciated.
The best way forward is to report this occurrence at the core project - if
it is not already reported.
Will you do that for us?.. please.


#9

This is a known issue, please don’t open a new issue for it:

https://github.com/atom/find-and-replace/issues/398


#10

Known problem? What odd in previous releases never had a problem with searching for projects containing multiple rows. Let’s hope they fix it, while I’m going to see other alternatives. I thank everyone who has devoted attention and tried to help me. Thank you all.