How to replace Notepad++ with Atom


#1

I’m uncertain on how I can get it to basically function with the same simplicity as Notepad++, but it seems to be a mess just to set Atom as the default program, having it open through console somehow. I wonder if someone could help me just get it to work like Notepad++ in that sense, set it as default, not having the weird loading time when opening it, removing everything called auto. Could anyone help me? Sorry if it’s badly explained.


#2

Well, you can always uninstall or disable any package you don’t want, in order to simplify it.

Regarding using it as the default editor. I am having no problem with that on Windows.
You just need to use the atom.cmd file as the executable to point to when selecting it as the default program for extensions.

I suppose the load time is the more difficult bit. We know that Atom can’t hold a candle to Notepad++, but then which other editor/IDE can?

That being said, a lot of improvements have been made so that today it’s certainly pretty fast compared to most other full-featured IDEs. It’s actually appropriate for the hybrid position it has between being a text editor and a full IDE (again, not counting N++).


#3

Thanks for the info

I just tried associating a file type with atom.cmd as above but I just get a terminal window open and close really quickly.
I also tried using AppData\Local\atom\app-0.190.0\atom.exe but windows seems to ignore this with the open with / choose default program option in explorers shortcut menu

TLDR - Above picture didn’t work, cannot find easy way to associate file types with Atom


#4

This is supposed to work. After the terminal window closes, you need to wait mere moments (not even an hour!) and then an Atom window should pop up. This is how it works on my Windows 7 machine at work.

Edit: What happens when you open a command window (cmd.exe or Powershell) and then run atom.cmd somefile from there? You may have to include the path to atom.cmd of course, and the path for some existing little text file. Perhaps there are some errors that help. Once it works from cmd.exe, it might even work when double-clicking the file…


#5

Thanks kgrossjo for the input

When I try to run it from the command prompt I get “The system cannot find the path specified.”

When I look at atom.cmd it is

rem @echo off
"%~dp0…\app-0.177.0\resources\cli\atom.cmd" %*

I have recently unintstalled atom and reistalled it so the old version looks suspicous.

Also to note I have tried to set the file associations to startmenu entry for atom

C:\Users[you]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\GitHub, Inc
but that didn’t work either

Think I am going to try reinstalling again after completely deleting the appData\atom folder


#6

I updated AppData\Local\atom\bin\atom.cmd with new path for new version and it worked but still going to reinstall to make sure everything is clean


#8

Works after cleaning and reinstalling. Dont get nice atom icon on files associated with it perhaps in the future it will


#9

I suppose that comes with the fact that it’s just a .cmd file that has no icons of its own (unlike .exe).
It’s just how Squirrel, the chosen installer, works. A lot of people would like that changed, so it’s possible that it will be at some point.