How to reopen the Sidebar on Atom?(sorry for stupid question)


#1

After I installed a plugin my sidebar disappeared…And I dont know how to reopen it.

It’s a little bit stupid… But I didnt find any related question before.


#2

I mean , the Folder view


#3

Nevermind…I solve it.

Reopen the ‘toggle tree view’
‘toggle tree view’


#4

Had a similar issue after I installed the sublime-tabs package (0.5.6) and then disabled it.

The problem was that the package disables the standard tree view and tabs feature, and they’re not enabled again when you disable/uninstall sublime-tabs.

Solution:

  1. ctrl-shift-p “Application: Open Your Config”
  2. remove"tree-view" (and “tabs”) from disabledPackages

#5

@andyhoff I had the same problem when I uninstalled Nuclide. Your solution indeed solves the problem. :+1:t2:


#6

@shanecarmody @andyhoff yep same here — uninstalling Nuclide moved “tree-view” into “disabledPackages”.


#7

I had the same problem after uninstalling Nuclide @shanecarmody andyhoff & callumflack


#8

Same issue after uninstalling Nuclide. Thanks @andyhoff for your solution! :grinning:


#9

Moreover, cmd-\ will reveal of hide the tree-view sidebar.


#10

When trying to open up Atom’s Side-Panel, do:

View -> Toggle-Tree-View

If that’s not working I would just simply drag & drop the project folder(s) and it’ll automatically bring it up. I find this to be the best method since you’ll probably already have the project folder up in an external file-browser anyways rather than using the built-in one and manually taking the time to find your folders you want to import.

Answer: Simply Drag-&-Drop the project folder(s) you want it could be a single one or more.


NOTE

  • Importing a root-folder of several sub-folders won’t allow you do remove the individual sub-folders.
    • So, it’s better to open up what you need in “that” root-folder and go ahead and select what you want or select all and filter out what you don’t want if that makes it easier for you.

:smiley:


#11

Thanks for your solution. I have met the same question when I uninstall nuclide.


#12

It’s insane that Nuclide does this, btw.


#13

Thank you!!! CTRL + \ was what I have been looking for!!!


#14

This happened to me after disabling Nuclide, thanks for posting!


#15

I once uninstall the package for Nuclide, and then messed up the tree-view. If you’re in the same situation and still doesn’t want to have Nuclide. Go to the Install -> search for tree-view; make sure it’s not disabled.


#16

Me as well, 9 months later still isn’t fixed.


#18

Thanks for posting! I uninstalled nuclide and used this solution. Then enabled tree view by going to menu bar -> view -> toggle tree view.


#19
  1. Go to VIEW-> Click on Toggle Tree View
    Now you will be able to see the side bar
  2. Ctrl + Backslash()
  3. Ctrl + Shift +P and then search tree and click on Tree View: Show