How to remove dictionary prompts on auto-complete plus?


#1

I like the autocomplete plus suggestions for my snippets. But I am not fond of the autocomplete suggestions for practically every word in the dictionary, including upper versus lower case versions of the same word.

Here are samples of the autocomplete suggestions I want to disable: https://www.screencast.com/t/C01nsR51 and https://www.screencast.com/t/q86NkjDWseH.

I know I can disable autocomplete plus entirely, but then I lose out on my snippet auto-complete prompts, which I do want. Any ideas on how I can keep snippet suggestions but disable others? I’m writing docs in Markdown files.


#2

The provider that suggests words it finds is the “built-in provider”. By default, it is blacklisted on Markdown files if you’re using the built-in Markdown support. It sounds like you have a community package for Markdown installed that uses a different scope descriptor for Markdown files. In any case, you can go into the autocomplete-plus package settings and uncheck “Enable Built-In Provider” to get rid of it altogether or you can add the scope for your community package’s flavor of Markdown into the blacklist for the built-in provider:


#3

Awesome. This totally fixed things for me. thanks for your help.