How to prevent Atom to snap to even columns?


#1

Is there any way to disable atom’s “snap-to-even-columns” feature?
I was trying to write this piece of code and I’ve noticed that indenting to odd columns is kind of painful in atom.
Try to manually write this snippet to understand what I’m talking about:

if panel_users_not_found.any?
  return {
           status: :ko,
           panel_users_not_found: panel_users_not_found
         }
end

#2

Settings -> Editor has a couple of indentation options. I think the most relevant is disabling Atomic soft tabs will let the cursor go on every space, instead of skipping in groups of <tab_length> when it’s leading whitespace.

On the other hand, I’ve never seen what you’re trying to do. I’d expect it to normally look like

if panel_users_not_found.any?
  return {
    status: :ko,
    panel_users_not_found: panel_users_not_found
  }
end

Or, if you want the braces to line up and get a lot of spacing,

if panel_users_not_found.any?
  return 
  {
    status: :ko,
    panel_users_not_found: panel_users_not_found
  }
end