How to make spell check word


#1

Hello good day,

I am new to atom.io, I see that the default spell-check package is already enable, but it seems not working.
Is there any guide out there, on how to configure the spell-check?

I am using atom 1.15 x64 on win10 and the only community package I installed is proton-mode.


#2

Can you share a screenshot of what you’re typing that isn’t getting spell checked? Also, what kind of file are you editing (plain text, Markdown ,etc.)?


#3

I am trying to edit go code. And try to use ctrl + :, and also try to bind it to other keymap. but still i dont how to make it work.


#4

Spellcheck is enabled by default for only a handful of file types, currently plain text, GFM, git commit messages, and AsciiDoc:

You can enable it for Go files in Settings > Packages > spell-check by adding source.go to the Grammars field:

spellcheck-settings

If enabled, spell check wouldn’t be limited to comments however though there’s an enhancement request for that /cc https://github.com/atom/spell-check/issues/19.


#5

Ohh thanks.