How to make autocomplete stop completing functions with "test(${1:int a});"?


#1

This is starting to be a deal breaker for me because I can’t figure it out. Whenever I auto complete a function, it inserts this http://imgur.com/a/tRmkB into the code. I only have Nuclide, Go-plus, and autocomplete plus installed.

It happens with Python, unless I uncheck “Autocomplete function parameters” in Nuclide. Then it stops.

However, testing it with C++, it happens there too. And there’s no settings for C++ in Nuclide.
It also happens with Go, using the Go-Plus package, even with Nuclide disabled and atom restarted.

I don’t know how to make this stop, and it’s happening with Python, C++, Go, and it’s starting to be a dealbreaker.

Can anyone help?
Thanks!


#2

found it, in case anyone is here in the future, I had disabled the “snippets” package and that’s what was doing it. For literally everything.