How to install linter-python-pep8 on windows7


#1

Follow the github’s installation, i accomplish the “apm install linter-python-pep8”.
But I don’t know how to set the config.cson on my windows7.
Hope someone can help me !


#2

If you’ve done both of the above, what is not working?


#3

Thanx for your help , I have already installed the linter package and the pep8 tool.
The problem is that I don’t know how to set the config.cson.
My config.cson is like this:

"*":
  core:
    autoHideMenuBar: true
    disabledPackages: [
      "linter-python"
    ]
    themes: [
      "atom-material-ui"
      "atom-material-syntax"
    ]
  editor:
    fontSize: 18
    invisibles: {}
  "exception-reporting":
    userId: "a4bbf76d-4c27-a6d4-bc0b-fc9f3a0dc516"
  linter: {}
  "linter-python": {}
  "one-dark-ui": {}
  welcome:
    showOnStartup: false
'linter-python-pep8':
  'pep8DirToExecutable': 'C:\python\Scripts'
  'ignoreErrorCodes': 'E501, W292'

#4

The linter-python-pep8 section should be indented one level deeper. Like this:

"*":
  core:
    autoHideMenuBar: true
    disabledPackages: [
      "linter-python"
    ]
    themes: [
      "atom-material-ui"
      "atom-material-syntax"
    ]
  editor:
    fontSize: 18
    invisibles: {}
  "exception-reporting":
    userId: "a4bbf76d-4c27-a6d4-bc0b-fc9f3a0dc516"
  linter: {}
  "linter-python": {}
  "one-dark-ui": {}
  welcome:
    showOnStartup: false
  'linter-python-pep8':
    'pep8DirToExecutable': 'C:\python\Scripts'
    'ignoreErrorCodes': 'E501, W292'

#5

Thanks , the config problem is soved,but when i coding the linter-python-pep8 does no reactive


#6

For that, you’ll probably have to file an Issue on the linter-python-pep8 package repository. Here are instructions for finding the repo for any Atom package: