How to install an Atom package on Windows 8 behind a proxy server?


#1

Hi

I want to install the atom-ctags package in Atom on Windows 8. I struggled to specify our proxy server in the .apmrc file so I thought I would install it directly from the command line:

C:\Windows\system32>apm install atom-ctags
Installing atom-ctags to C:\Users<snip>.atom\packages failed
Request for package information failed: connect ETIMEDOUT

As you can see it failed. Am I doing this incorrectly?

BR

David


#2

See my reply to your post on the other topic:

Assuming your username is DavidA, this would mean that your home directory is C:\Users\DavidA and would mean that your Atom configuration directory is in C:\Users\DavidA\.atom. This would put the .apmrc file at C:\Users\DavidA\.atom\.apmrc. (@batjko or @mark_hahn please correct me if my understanding of Windows Atom use is incorrect.)

Also note that whether you install packages at the command line or through the Settings View, they’re both using apm under the covers. It makes no difference.


What Port Does Atom Package Installer Use?
#3

Thanks for your reply. The following folder exists as you suggested:

C:/Users/DavidA/.atom

but it does not contain a .apmrc file. Should I just create the file there?


#4

Yes, go ahead and just create it.


#5

Ok, I created the .apmrc file (not so easy on Windows because it doesn’t like not specifying a file name, but I got around it using ren from the command line to rename the file) and inserted:

https-proxy = http://172.xx.xx.1:3128
http-proxy = http://172.xx.xx.1:3128
strict-ssl = false

(with proper ip addresses - I inserted the x’s here intentionally).

Atom now reports:

npm WARN invalid config https-proxy=“�http://172.xx.xx.1:3128”

npm WARN invalid config Must be a full url with ‘http://’

connect ETIMEDOUT

Any idea why this is so please?


Proxy settings not fully respected in windows (still not working, please consider reopening)
#6

It didn’t like the spaces.

https-proxy=http://172.xx.xx.1:3128
http-proxy=http://172.xx.xx.1:3128
strict-ssl=false

works fine. Thanks for your help.


#7

You’re welcome. I’m glad I could help :grinning:


#8

hey ,I have a similar problem .it just like this:
Request for package information failed: tunneling socket could not be established, cause=connect ETIMEDOUT

I am live in China an there is a Firewall.
this is my .apmrc:
cache = ~/.atom/.apm
strict-ssl=false
https-proxy=https://9.0.2.1:0

Is there any way to solve it ?please help me.


#10

It sounds like it can’t connect to the proxy. Are you sure that the address you have given is correct? I’m not sure that port 0 is valid.


#11

I have change it like this :
cache = ~/.atom/.apm
https-proxy=http://127.0.0.1:8087
http-proxy=http://127.0.0.1:8087
strict-ssl=false
but it still doesn’t work well.
this is my apm:
C:\Users\Christopher>apm -v
apm 0.101.0
npm 1.4.4
node 0.10.32
python 2.7.7
git 1.9.4.msysgit.0
visual studio 12
Is there any similar problem?
and this is the problem output:
Installing “autocomplete-clang@0.2.0” failed.Hide output…

gyp info it worked if it ends with ok
gyp info using node-gyp@0.12.2
gyp info using node@0.10.32 | win32 | ia32
gyp http GET https://gh-contractor-zcbenz.s3.amazonaws.com/atom-shell/dist/v0.17.0/node-v0.17.0.tar.gz
gyp http 502 https://gh-contractor-zcbenz.s3.amazonaws.com/atom-shell/dist/v0.17.0/node-v0.17.0.tar.gz
gyp WARN install got an error, rolling back install
gyp


Failed to install autocomplete-clang package
#12

To my understanding, this part should work:

https-proxy=http://127.0.0.1:8087
http-proxy=http://127.0.0.1:8087
strict-ssl=false

So long as those are the right values for your proxy server. I don’t know what the right values are for your proxy server and can’t speculate.


#13

On Windows as soon as I opened C:\Users\<me>\.atom\ i saw the folder .apm which had the .apmrc file and I started editing that which eventually got replaced. Big mistake!

So if you have been doing the same mistake and cant get proxy settings to work as leedohm has mentioned please create a .apmrc file in folder C:\Users\<me>\.atom\ and not inside C:\Users\<me>\.atom\.apm\


#14

@JinLingChristopher

hi,I am a chinese too. And I has the same problem with you. I want to know how you resove the proxy problem Request for package information failed: tunneling socket could not be established, cause=connect ETIMEDOUT when install a package ? thx.


#15

On windows, it works for me, creating the file:
c:\Users<me>.atom.apmrc

and adding:
http-proxy = http://:password@proxy.domain:8080
https-proxy = http:/:password@proxy.domain:8080


#16

I know this is old, but…

Windows 7 - behind corporate proxy

The settings that FINALLY worked for me in .apmrc are these:

http-proxy=http://proxy-server-name:port#
https-proxy=http://proxy-server-name:port#

I tried a lot of other settings. These worked. Substitute your own proxy server name and port, of course. But our proxy server is just http:// and I think that was what I was missing at first.


#17

This works perfectly for me.:slight_smile:


#18

If you are on a firewall that needs password authentication you may need this:

https-proxy=http://myUsername:myStrongPassword@internet-proxy.your.company.com:80
http-proxy=http://myUsername:myStrongPassword@internet-proxy.your.company.com:80
strict-ssl=false

Just copy these lines to your cmd / powershell to create the file:

echo https-proxy=http://myUsername:myStrongPassword@internet-proxy.your.company.com:80>%USERPROFILE%\.atom\.apmrc
echo http-proxy=http://myUsername:myStrongPassword@internet-proxy.your.company.com:80>>%USERPROFILE%\.atom\.apmrc
echo strict-ssl=false>>%USERPROFILE%\.atom\.apmrc

#19

Works fine on Windows 7 Enterprise. In username, don’t needed the domain name server, only the username.