How to hide .DS_Store files in the tree view?


#1

I already tried adding .DS_Store on the Settings > Core Settings > Ignored Names section, but it doesn’t work.

I also checked other topics about that but the UI has changed.

My config file is ok and I am using the latest version.

‘ignoredNames’: [
’.DS_Store’


#2

The Ignored Names setting doesn’t affect the Tree View by default. But in the settings for the Tree View package you can find a setting called “Hide Ignored Names” as explained in my post here:

The rest of that topic has links to other helpful information regarding hiding or showing ignored names and Git ignored files.


#3

Yes that has tripped up people before. I’s not obvious that the Ignored Names setting only does what it says on the tin, if the tree view package itself has another setting switched on.

This could use some work, either via a toast notification when changing the global setting if the tree view setting is off, or maybe by moving the “Hide ignored names” checkbox right above the “Ignored Names” field, to keep them together.


#4

Wow, thanks.

I got it. I was trying to set it through the settings, didn’t know that Tree View package has its own settings tab.


#5

For anyone looking at this more recently, they have moved the tree view settings to the settings for the specific package. Go to Preferences -> Packages (tab) -> search for tree-view -> click settings -> check “Hide Ignored Names”.