How to get rid of welcome.md


#1

Whenever I start atom, I get this annoying welcome.md tab.

I tried deactivating the welcome package. I tried uninstalling the package and my config has 2 lines like this:

  'welcome':
    'showOnStartup': false

How to I get rid of this tab?


#2

If disabling the package doesn’t work, then I would assume that the config.cson isn’t being read on startup. Try this:

  1. Open a fresh instance of Atom
  2. Open the Developer Tools: View > Developer > Toggle Developer Tools
  3. Switch to the Console tab
  4. Enter the command: atom.config.getUserConfigPath()

Is the path returned the same path as the config.cson you’re looking at?


#3

atom.config.getUserConfigPath()
"/Users/kait/.atom/config.cson"

And this is also the file I’m looking at when I’m doing “Atom -> Open your config”


#4

What about when you execute: atom.config.get('welcome.showOnStartup')


#5

atom.config.get(‘welcome.showOnStartup’)
false


#6

Then try this:

  1. Exit Atom completely
  2. Execute from the command line: mv /Users/kait/.atom/storage /Users/kait/.atom/storage-backup
  3. Start Atom again

#7

Wohoo, now it works! Thanks!


#8

Added this topic as a reference on my feature request for easily blowing away ~/.atom/storage:


#9

Sorry for resurrecting this topic. I still get a welcome page every time I open atom. Even after nuking the storage file. In fact I get the welcome page, and the welcome guide. Should I post an issue on github?


#10

No. Just uncheck the “Show Welcome Guide when opening Atom” box.


#11

Well that is bizarre. It’s good I asked here first.


#12

Toogle Developer Tools like it is described in earlier post:

And call command:
atom.config.set('welcome.showOnStartup', false);


#13

The easiest method is following the description I posted above:


#14

I too had this issue, and from time to time try the different fancy suggestions listed here with little result. In the end, and in desperation I simply deleted ./.atom/config.cson, and restarted atom. It created a new one;

“*”:
core:
telemetryConsent: “no”
“exception-reporting”:
userId: "99999999-fb66-476c-913b-f9999999999"
welcome:
showOnStartup: false

and all is well now.
OBTW not my actual userid


#15

I’m not sure why people are continuing to post far more complex solutions to this. The solution is simple, uncheck this box:

I’m going to close this topic and create a FAQ saying the same thing to prevent people from being misled.


#16

#17

Here’s the FAQ too: