How to fix an autocomplete patckage


#1

I’m using an autocomplete package and for some reason the autocomplete menu seems to pop up with absolutely everything, not just recognised words that are real code functions. Even punctuation like : , etc and even spaces! So whenever I press enter it’s autocompleting nothing at all and adding words that I don’t need at all. Somewhat annoying. I posted it as an issue for the package but who knows if anyone will every look at it.

Is there some way I can edit the package myself and fix this? Because other than that it’s of course useful and is the only package for this language anyway.


#2

It would help if you told us which autocomplete package it is. Is the dropdown always popping up with suggestions from that specific language? Did you start seeing the problem only after installing that specific package?


#3

Yes it’s only with this package, it’s clearly an error with this package. It’s the GML autocomplete. If I type with another language and another autocomplete package there are no problems of course. That’s why I want to know how to edit packages and fix this issue if possible although I’m guessing it might not be that easy.


#4

The code that determines when suggestions pop up for GML is here.

This is a setting for the autocomplete-plus package:

Note the last bit of the description. My thinking is that if the word length setting isn’t binding on external providers, it might be that autocomplete-gml is enforcing its own expectation regarding word length. The only thing is that, when I look at the code, I can’t identify anywhere that such a thing might be happening.


#5

Yeah that’s weird. It seems like a buggy program…quite similar to gamemaker itself really.