How to enable font subpixel antialiasing?


#1

I’m on OS X El Capitan with a retina display.

I’ve tried setting -webkit-font-smoothing to subpixel-antialiased, antialiased and auto but none of them uses subpixel antialiasing.

Here’s how text looks like in TextEdit, with subpixel antialiasing (top), and the same in Atom, with the One Light themes and all settings at default (bottom):


#2

I suspect that Chromium doesn’t use subpixel antialiasing on Retina displays. (At least in my testing, it doesn’t.) And since Atom uses Chromium for the rendering engine, this would be why it isn’t happening. Please file an Issue on the https://github.com/atom/atom repository so we can see about answering the question of whether this is possible or if Chromium simply refuses.