How to disable substring autocompletion


#1

Using the default atom/autocomplete package (v0.32.0), How do get it to only show completion entries which have the prefix I have typed.

For example in the image substring matching seems to be used, I would like it to only show completions starting with AST


#2

Does something starting with AST already exist within the file (or the project if you have “Include Completions From All Buffers” enabled)? Atom isn’t familiar with the standard libraries of Haskell, so it can’t predict what you’re trying to type unless it has something to go on.

I wrote this simple test to illustrate:

Notice that it doesn’t even suggest FastBool because ASTRING is such a good match.


#3

Thanks, that was useful (I don’t have “Include Completions From All Buffers”)